Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.92) (envelope-from ) id 1j7ius-00029u-QH for pgsql-hackers@arkaria.postgresql.org; Fri, 28 Feb 2020 16:55:10 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1j7iur-0007z0-L1 for pgsql-hackers@arkaria.postgresql.org; Fri, 28 Feb 2020 16:55:09 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1j7iur-0007yt-By for pgsql-hackers@lists.postgresql.org; Fri, 28 Feb 2020 16:55:09 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1j7iup-00019M-5z for pgsql-hackers@postgresql.org; Fri, 28 Feb 2020 16:55:08 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id 01SGt5RT017965; Fri, 28 Feb 2020 11:55:05 -0500 From: Tom Lane To: Peter Eisentraut cc: pgsql-hackers Subject: Re: HAVE_WORKING_LINK still needed? In-reply-to: <72fff73f-dc9c-4ef4-83e8-d2e60c98df48@2ndquadrant.com> References: <72fff73f-dc9c-4ef4-83e8-d2e60c98df48@2ndquadrant.com> Comments: In-reply-to Peter Eisentraut message dated "Fri, 28 Feb 2020 14:14:51 +0100" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <17963.1582908905.1@sss.pgh.pa.us> Date: Fri, 28 Feb 2020 11:55:05 -0500 Message-ID: <17964.1582908905@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Peter Eisentraut writes: > I came across the HAVE_WORKING_LINK define in pg_config_manual.h. > AFAICT, hard links are supported on Windows and Cygwin in the OS > versions that we support, and pg_upgrade already contains the required > shim. It seems to me we could normalize and simplify that, as in the > attached patches. (Perhaps rename durable_link_or_rename() then.) I > successfully tested on MSVC, MinGW, and Cygwin. I don't have any way to test on Windows, but this patchset passes eyeball review. +1 for getting rid of the special cases. Also +1 for s/durable_link_or_rename/durable_link/. regards, tom lane