public inbox for [email protected]
help / color / mirror / Atom feedFrom: Peter Eisentraut <[email protected]>
To: Robert Haas <[email protected]>
To: Nikolay Samokhvalov <[email protected]>
Cc: [email protected]
Subject: Re: Proposals for EXPLAIN: rename ANALYZE to EXECUTE and extend VERBOSE
Date: Thu, 7 Nov 2024 07:55:24 +0100
Message-ID: <[email protected]> (raw)
In-Reply-To: <CA+TgmoZF7PbO7DB_VMQS4664EgOdObhFtAoLUb83bp3i-623UQ@mail.gmail.com>
References: <CANNMO++9W_UA8PB9AkDRF3JBv4K7K1FnisrXTjicL+WZhwUJzw@mail.gmail.com>
<CA+TgmoZF7PbO7DB_VMQS4664EgOdObhFtAoLUb83bp3i-623UQ@mail.gmail.com>
On 05.11.24 19:19, Robert Haas wrote:
>> 1) EXPLAIN ANALYZE Is sometimes very confusing (because there is ANALYZE). Let's rename it to EXPLAIN EXECUTE?
> The trouble is that EXPLAIN EXECUTE already means something.
>
> robert.haas=# explain execute foo;
> ERROR: prepared statement "foo" does not exist
>
> Granted, that would not make it impossible to make EXPLAIN (EXECUTE) a
> synonym for EXPLAIN (ANALYZE), but IMHO it would be pretty confusing
> if EXPLAIN EXECUTE and EXPLAIN (EXECUTE) did different things.
At some point in the past, the idea of renaming EXPLAIN ANALYZE to
PROFILE was thrown around. I still kind of like that idea. You'd have
to keep the existing syntax around, of course.
view thread (20+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected]
Subject: Re: Proposals for EXPLAIN: rename ANALYZE to EXECUTE and extend VERBOSE
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox