Subject: Re: How to store chinese using the Postgresql?

From: "Shridhar Daithankar" <[email-masked]>
Date: Mon, 28 Oct 2002 19:31:54 +0530

On 27 Oct 2032 at 0:24, Timothy Chan wrote:

> 
> Hi
>  i would like to use postgresql to store any data (some include chinese), 
> but when i access the chinese data inpostgresql, i can't get back correct 
> data, it return any unknow word/data to me.
> How can i solve it? i am using the RedHat Linux 7.2 and Postgresql 7.1, and i 
> haven't install CLE on Linux.

You might have done this but just confirrming, did you use initdb -E to enable 
proper locale?

Bye
 Shridhar

--
"I would rather spend 10 hours reading someone else's source code than10 
minutes listening to Musak waiting for technical support which isn't."(By Dr. 
Greg Wettstein, Roger Maris Cancer Center)

---

From: Tatsuo Ishii <[email-masked]>
Date: Mon, 28 Oct 2002 23:21:43 +0900 (JST)

>     i would like to use postgresql to store any data (some include chinese), but when i access the chinese data in postgresql, i can't get back correct data, it return any unknow word/data to me.
> How can i solve it? i am using the RedHat Linux 7.2 and Postgresql 7.1, and i haven't install CLE on Linux.

Define "chinese." What character set for Chinese are you using?
--
Tatsuo Ishii

---

From: "Timothy Chan" <[email-masked]>
Date: Wed, 27 Oct 2032 00:24:21 +0800

Hi

Thanks
Tim