Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1av4qA-00085o-LF for pgsql-hackers@arkaria.postgresql.org; Tue, 26 Apr 2016 15:23:54 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1av4qA-0005cx-7d for pgsql-hackers@arkaria.postgresql.org; Tue, 26 Apr 2016 15:23:54 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1av4om-0002C0-Sg for pgsql-hackers@postgresql.org; Tue, 26 Apr 2016 15:22:28 +0000 Received: from out.smtp-auth.no-ip.com ([8.23.224.60]) by magus.postgresql.org with esmtps (TLS1.0:DHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.84_2) (envelope-from ) id 1av4oi-00016L-ED for pgsql-hackers@postgresql.org; Tue, 26 Apr 2016 15:22:28 +0000 X-No-IP: alvh.no-ip.org@noip-smtp X-Report-Spam-To: abuse@no-ip.com Received: from alvin.alvh.no-ip.org (unknown [186.103.176.74]) (Authenticated sender: alvh.no-ip.org@noip-smtp) by smtp-auth.no-ip.com (Postfix) with ESMTPA id C07BC400A65; Tue, 26 Apr 2016 08:22:19 -0700 (PDT) Received: by alvin.alvh.no-ip.org (Postfix, from userid 1000) id DF0FF431; Tue, 26 Apr 2016 12:22:17 -0300 (CLT) Date: Tue, 26 Apr 2016 12:22:17 -0300 From: Alvaro Herrera To: Robert Haas Cc: Tom Lane , Magnus Hagander , Bruce Momjian , PostgreSQL-development Subject: Re: Rename max_parallel_degree? Message-ID: <20160426152217.GA548975@alvherre.pgsql> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: User-Agent: Mutt/1.5.23 (2014-03-12) X-Pg-Spam-Score: -1.1 (-) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org Robert Haas wrote: > On Mon, Apr 25, 2016 at 2:58 PM, Alvaro Herrera > wrote: > > What about calling it something even simpler, such as "max_parallelism"? > > This avoids such cargo cult, and there's no implication that it's > > per-query. > > So what would we call the "parallel_degree" member of the Path data > structure, and the "parallel_degree" reloption? I don't think > renaming either of those to "parallelism" is going to be an > improvement. I think we should define the UI first, *then* decide what to call the internal variable names. In most cases we're able to call the variables the same as the user-visible names, but not always and there's no rule that it must be so. Having source code variable names determine what the user visible name is seems to me like putting the cart before the horse. I think the word "degree" is largely seen as a bad idea: it would become a somewhat better idea only if we change how it works so that it matches what other DBMSs do, but you oppose that. Hence my proposal to get rid of that word in the UI. (My first thought yesterday was to look for synonyms for the "degree" word, so I got as far as "amount of parallelism" when I realized that such accompanying words add no value and so we might as well not have any word there.) -- Álvaro Herrera http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers