Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hQH6E-0002Is-2z for pgsql-hackers@arkaria.postgresql.org; Mon, 13 May 2019 19:59:02 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1hQH6C-0002uL-Sg for pgsql-hackers@arkaria.postgresql.org; Mon, 13 May 2019 19:59:00 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hQH6C-0002uE-Gy for pgsql-hackers@lists.postgresql.org; Mon, 13 May 2019 19:59:00 +0000 Received: from mail-qt1-x842.google.com ([2607:f8b0:4864:20::842]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hQH69-00076E-Hp for pgsql-hackers@postgresql.org; Mon, 13 May 2019 19:58:58 +0000 Received: by mail-qt1-x842.google.com with SMTP id o7so16298133qtp.4 for ; Mon, 13 May 2019 12:58:57 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=2ndquadrant-com.20150623.gappssmtp.com; s=20150623; h=date:from:to:cc:subject:message-id:mime-version:content-disposition :content-transfer-encoding:in-reply-to:user-agent; bh=PVfK+jSca21MxpN3GhPzBJn+jqNSCTl14StiOQ4XAss=; b=Nh1jeJLzmIhncijZdAmOkPCjbn28AUWC/nDu5tfcHvA0X61syx/uc02Si0f+mds3vW ySUhkSxdndQDcWbBfPM4CvSl9JdwVlrnqf9p6F4lcAb8D6ItJhagroQ5RSUzE/zt+gCn xnDO7MPrAINa6gynZ5t17xGxkjbhS0p3s2LuEQCO3OToXotNqYRJzv/WFRYWXWGvbb7P ZiHPVzNZ74zfNfEn4HZOyZmvb35qVy/woe5TRq/NOHMDaP2kfUuIU1+nX+jdcVRroHZr p08mfaI9YQh/M+2olhr4bDMMD3o2REi9v+YnaYP7Icdj4knKwrUngo/EIREVNbbVAqjK zgAw== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:date:from:to:cc:subject:message-id:mime-version :content-disposition:content-transfer-encoding:in-reply-to :user-agent; bh=PVfK+jSca21MxpN3GhPzBJn+jqNSCTl14StiOQ4XAss=; b=QL4gQ4iSByng40oLdU0QXhrLUawJeO2R098Qb/GossMTR9OKRhJZducFdwWl3S4kpz bmbEXshR1J/UthwKD5PRQxazNrPtKt4H816+dyyp+prKV6YKBAIvEVZeO1Z7wI6Fk//n aDyhWJRQNmC52Nrc4uO5s5hIBVl0MVkfNfi3reI6i35rmOhcAo4NSVj6qG/xmPIdrm1V 3SMSqElGLAxBND6A1U2iV3ozAiPRgn8GlL+HNMD+PEe5OnB2qniVTzmj+xk0GGMYkRzA 1tCcfwMtKPqY6zwd9mE4KM+X/JtaK2mrBculwu9uCu1RKCD9R+1Rp1TkWHMzMx8ixsr8 SO3A== X-Gm-Message-State: APjAAAV4dI8nE9aL93TChrS6p5hjqxh1hFslSd2b0mo27tZhM9HvE41B OEk10aVRpivoudbd2lg/DXmOGA== X-Google-Smtp-Source: APXvYqzLI1nPOuvDJKHwetZkoZjzSoEHEdu+QF2Fv0TZ6ToCX1igNxuHQJnxdPp1ntktEopt/b4pHg== X-Received: by 2002:ac8:294c:: with SMTP id z12mr26070002qtz.79.1557777536770; Mon, 13 May 2019 12:58:56 -0700 (PDT) Received: from nimloth.alvh.no-ip.org ([190.217.219.6]) by smtp.gmail.com with ESMTPSA id p37sm12077772qtj.90.2019.05.13.12.58.55 (version=TLS1_2 cipher=ECDHE-RSA-CHACHA20-POLY1305 bits=256/256); Mon, 13 May 2019 12:58:56 -0700 (PDT) Received: by nimloth.alvh.no-ip.org (Postfix, from userid 1000) id B2A29120B12; Mon, 13 May 2019 15:58:51 -0400 (-04) Date: Mon, 13 May 2019 15:58:51 -0400 From: Alvaro Herrera To: Tom Lane Cc: Peter Eisentraut , Ian Barwick , "pgsql-hackers@postgresql.org" Subject: Re: PG12, PGXS and linking pgfeutils Message-ID: <20190513195851.GA10077@alvherre.pgsql> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <9755.1557775997@sss.pgh.pa.us> User-Agent: Mutt/1.9.4 (2018-02-28) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk On 2019-May-13, Tom Lane wrote: > I started working on a patch to do that, and soon noticed that there > are pre-existing files logging.[hc] in src/bin/pg_rewind/. This seems > like a Bad Thing, in fact the #includes in pg_rewind/ are already a > little confused due to this. I think we should either rename those > two pg_rewind files to something else, or rename the generic ones, > perhaps to "fe_logging.[hc]". The latter could be done nearly > trivially as part of the movement patch, but on cosmetic grounds > I'd be more inclined to do the former instead. Thoughts? I'd rename both :-) -- Álvaro Herrera https://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services