Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1igWjo-0005wK-A4 for pgsql-hackers@arkaria.postgresql.org; Sun, 15 Dec 2019 16:27:20 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1igWjn-0002xS-4j for pgsql-hackers@arkaria.postgresql.org; Sun, 15 Dec 2019 16:27:19 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1igWjm-0002rM-H8 for pgsql-hackers@lists.postgresql.org; Sun, 15 Dec 2019 16:27:18 +0000 Received: from mail-yb1-xb2d.google.com ([2607:f8b0:4864:20::b2d]) by makus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1igWjj-0001PR-Tq for pgsql-hackers@postgresql.org; Sun, 15 Dec 2019 16:27:17 +0000 Received: by mail-yb1-xb2d.google.com with SMTP id i72so1945903ybg.3 for ; Sun, 15 Dec 2019 08:27:15 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=telsasoft-com.20150623.gappssmtp.com; s=20150623; h=date:from:to:cc:subject:message-id:references:mime-version :content-disposition:in-reply-to:user-agent; bh=29X5wioIvEqxL03LxZ8DDLimbQ16W42zCOQWgWbu4aE=; b=JtSsXFwCltRCU0BFmL7ynU3QiKOf0FB8CtEdaNRSdg4Lez0C0gNomjwxpdYXuV561Y CAR2Nfj22OFRCd62ObYCMIhSFTbYPy/9PuLHdQiB4UlFa0C4ST9xlN+qpIMaQmO8MDtN FbweV82f4sKllLJEvjl+2OtM87fOgpnWw4Qxrjos35D54VAYDIGwhItd4+gt5y8ERVjM xReExAY3s4oikBtVdQVvrw8URwhZQa/nyPqa51N1HFxdhVBuo3+Ape4pDd7CBwqRtOrM ZFnyq8wVBEaga7hJ/EddEXXp7iLGMd4vrarJ//qKDxx9aX3fnSfBaSlknLfVSMUkIfSG 1nFg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-disposition:in-reply-to:user-agent; bh=29X5wioIvEqxL03LxZ8DDLimbQ16W42zCOQWgWbu4aE=; b=hLoSTXk6x9QVc2VfBe+9m9GzT5dl0vFxBVqGlbJ2d4bCgM1YBlFl+ynTX7ePQPciic XUTrX7L27wOI0RKAOx2oI0BCGj7VEm7zopSTPE2DLCGNDC3esesuUWucigZZJG0QoT1K oSWsvr1KKyBLctS2EiJA2yLm0bc/ZYfAmgrDWrOg5P06DNJJb35hokabCpLQk3JAsqra VHeDg/cKznajniZLtaAl8giSFoTwDrblEc5REV0FYa9HqzDOEEOKkBW3NRjs6bO0jyNi KBW5p0OFR6jRo82rX4XELM+BRqs4+WWOt4fIYf2+57geWKsUHGHoAsSICbLlvKGmGbob 9VKQ== X-Gm-Message-State: APjAAAVWYN5cxeX0DBT0W5PIyOOUZ5nrpr8rj8Yfypfn+REUM+sivN3i BzrX9UdIyWUG0rmzvE8j8elipA== X-Google-Smtp-Source: APXvYqyra7y8B/ctVxc6wKbVHNwR9clWKrWk8rp5Z/WKNspWW1OYY3HebURa8meagWNgUt5JTyjBmg== X-Received: by 2002:a25:4b85:: with SMTP id y127mr17188463yba.238.1576427234962; Sun, 15 Dec 2019 08:27:14 -0800 (PST) Received: from pryzbyj (charmander.telsasoft.com. [50.244.222.1]) by smtp.gmail.com with ESMTPSA id i72sm7041246ywg.49.2019.12.15.08.27.13 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Sun, 15 Dec 2019 08:27:14 -0800 (PST) Received: by pryzbyj (Postfix, from userid 1000) id CAE68800A33; Sun, 15 Dec 2019 10:27:12 -0600 (CST) Date: Sun, 15 Dec 2019 10:27:12 -0600 From: Justin Pryzby To: Michael Paquier Cc: Alvaro Herrera , Andres Freund , pgsql-hackers@postgresql.org Subject: Re: error context for vacuum to include block number Message-ID: <20191215162712.GZ2082@telsasoft.com> References: <20191211165425.4ewww2s5k5cafi4l@alap3.anarazel.de> <20191211153353.GA23008@alvherre.pgsql> <20191213030831.GT2082@telsasoft.com> <20191213132850.GA103520@paquier.xyz> <20191213224735.GY2082@telsasoft.com> <20191215130708.GA19063@paquier.xyz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20191215130708.GA19063@paquier.xyz> User-Agent: Mutt/1.5.24 (2015-08-30) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk On Sun, Dec 15, 2019 at 10:07:08PM +0900, Michael Paquier wrote: > On Fri, Dec 13, 2019 at 04:47:35PM -0600, Justin Pryzby wrote: > > It's related code which I cleaned up before adding new stuff. Not essential, > > thus separate (0002 should be backpatched). > > The issue just causes some extra work and that's not a bug, so applied > without a backpatch. Thanks > For 0003, I think that lazy_vacuum_heap_index() can be confusing as > those indexes are unrelated to heap. Why not naming it just > lazy_vacuum_all_indexes()? The routine should also have a header > describing it. I named it so because it calls both lazy_vacuum_index ("PROGRESS_VACUUM_PHASE_VACUUM_INDEX") and lazy_vacuum_heap("PROGRESS_VACUUM_PHASE_VACUUM_HEAP") I suppose you don't think the other way around is better? lazy_vacuum_index_heap Justin