Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jZeMl-0006RD-PJ for pgsql-hackers@arkaria.postgresql.org; Fri, 15 May 2020 17:43:23 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1jZeMk-0005IX-IS for pgsql-hackers@arkaria.postgresql.org; Fri, 15 May 2020 17:43:22 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jZeMk-0005Fh-29 for pgsql-hackers@lists.postgresql.org; Fri, 15 May 2020 17:43:22 +0000 Received: from mail-qt1-x842.google.com ([2607:f8b0:4864:20::842]) by makus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1jZeMd-0007MY-8P for pgsql-hackers@lists.postgresql.org; Fri, 15 May 2020 17:43:20 +0000 Received: by mail-qt1-x842.google.com with SMTP id x12so2637104qts.9 for ; Fri, 15 May 2020 10:43:15 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=2ndquadrant-com.20150623.gappssmtp.com; s=20150623; h=date:from:to:cc:subject:message-id:mime-version:content-disposition :content-transfer-encoding:in-reply-to:user-agent; bh=Avsa9D0jROvOjR+I7ZeQkfPYInblIjK+lRZ5W6tDyTQ=; b=Kq2M8NP/jP6rXBoMO/3GKHLoSAN6T9mtbFjr39DKj7kycEo3vz9wihSShUjB8gM7d6 yEuW4C4eZUChd8+Ptb//qQutT0+cyGbKEEV475EeLOlxAmQzQYUp+BglKYj2hx0188ta TcGzpmH2Ru8HOHYtUqfIhs8uoO6RIVNFP0whHtDhh+wjgk9dbiqxtQK5osTIpXg/HfBW Z54qb94iNnlg/ueFWc3atUVa2X52CpnT5VYUc0ViT0G4wzbL7il+CiCIkzihO4bOdg2Q oS5g1hG94SMDvNwKWotwIq6Y3HzD3sor8vV/ulSyu0VSBnHaFIar1ioppWzPzqq2gALC Nzzg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:date:from:to:cc:subject:message-id:mime-version :content-disposition:content-transfer-encoding:in-reply-to :user-agent; bh=Avsa9D0jROvOjR+I7ZeQkfPYInblIjK+lRZ5W6tDyTQ=; b=R4KTzrhpsnt3263/JoPrB6ieOtHeL3dAq9iBKAQN70mM9C5G0oxyS9El4j7p/f9S+Y i3oUYe/poLpNertky37NN5szIrYnw2FZDYw9iv68NSHBez5tjCTC1D6XAuLABNDUFj9u a/PeWE0M7VoEt5Lyk5g68Vh3kJyde5BLVrsaJQlPNmETnf/0FCKpJFaZQLtfwlQWkSnA r0Qj7U5b7HhNRXjpCJg1RntqT9McbG7BnDNUJ+1C7iFn6HVuBx3aAPi8CAVtezRHnlK4 NtmRL/68BhVXyRniouK8Dpk8qoH9TItuLzMndYH02l+uVIzILkhiz4Lv10n/+bpQwxi2 6kxQ== X-Gm-Message-State: AOAM530EUR0alO+vWARTDJY7wHosJ+kUDq0StYKuUdwRjscXUUBNY3EI gaGeEVdwjGJttkrclU7QIMOdYA== X-Google-Smtp-Source: ABdhPJxpqHdL2bwXLIZFxnkboICzghLdT5IwgXW7DEC0zTiVTQmkDw1dj/mvqDu9CySp4+pqkSFiLg== X-Received: by 2002:ac8:714c:: with SMTP id h12mr4725582qtp.372.1589564594078; Fri, 15 May 2020 10:43:14 -0700 (PDT) Received: from nimloth.alvh.no-ip.org ([190.95.18.252]) by smtp.gmail.com with ESMTPSA id g126sm2146024qkf.34.2020.05.15.10.43.13 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Fri, 15 May 2020 10:43:13 -0700 (PDT) Received: by nimloth.alvh.no-ip.org (Postfix, from userid 1000) id 4F25D3006AA; Fri, 15 May 2020 13:43:11 -0400 (-04) Date: Fri, 15 May 2020 13:43:11 -0400 From: Alvaro Herrera To: Michael Paquier Cc: Postgres hackers , Thomas Munro Subject: Re: pg_stat_wal_receiver and flushedUpto/writtenUpto Message-ID: <20200515174311.GA2699@alvherre.pgsql> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <20200515090817.GA212736@paquier.xyz> User-Agent: Mutt/1.10.1 (2018-07-13) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk On 2020-May-15, Michael Paquier wrote: > As discussed in the thread that introduced d140f2f3 to rename > receivedUpto to flushedUpto and add writtenUpto to the WAL receiver's > shared memory information, the equivalent columns in > pg_stat_wal_receiver have not been renamed: > When I have implemented this system view, the idea was to keep a > one-one mapping between the SQL interface and the shmem info even if > we are not compatible with past versions, hence I think that before > beta1 we had better fix that and: > - rename received_lsn to flushed_lsn. > - add one column for writtenUpto. Why do you put the column at the end? I would put written_lsn before flushed_lsn. Since this requires a catversion bump, I think it'd be best to do it before beta1 next week. -- Álvaro Herrera https://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services