Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1m09Px-0002YI-OJ for pgsql-hackers@arkaria.postgresql.org; Sun, 04 Jul 2021 21:12:45 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1m09Pw-0004lm-Ip for pgsql-hackers@arkaria.postgresql.org; Sun, 04 Jul 2021 21:12:44 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1m09Pw-0004le-Ay for pgsql-hackers@lists.postgresql.org; Sun, 04 Jul 2021 21:12:44 +0000 Received: from mail-pj1-x102d.google.com ([2607:f8b0:4864:20::102d]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1m09Ps-0004Sf-32 for pgsql-hackers@lists.postgresql.org; Sun, 04 Jul 2021 21:12:43 +0000 Received: by mail-pj1-x102d.google.com with SMTP id n11so10488198pjo.1 for ; Sun, 04 Jul 2021 14:12:39 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=leadboat.com; s=google; h=date:from:to:cc:subject:message-id:references:mime-version :content-disposition:in-reply-to:user-agent; bh=+ABAYozEjNe+PasCZMTo3tiFETxgf8yOYbBMeIILXKA=; b=cuPpyAzD5Ax2c/z8KDTaSsrbJX0k8MgbcwEgPnxuGwUN9j9UIBPVgs6Rok2MjrdDz+ hWW1P+K4GsF3kg8WFdJPb3Y50BJRFWRWuEcuv4egiMNwuvd9lWI41LzbGnBi3uEKTX3+ y5/JqixMDivX2unCjG00zQROt9T5AbQ5ZyKPY= X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-disposition:in-reply-to:user-agent; bh=+ABAYozEjNe+PasCZMTo3tiFETxgf8yOYbBMeIILXKA=; b=dY1nu1XT/ogimIOulpCfAl3++P5fSozYydMKlhUHKGCFP755NQsE4T3elviV3/WGji fLbtcXOE6EhOBAmhMXS7ghPFEzOO+ahHB+ft5cbqLLsDCDYrrNJF7ukXJ2IJ4tXpdqiN SXYfSIVw1EoH9Gn1d/veHpjoUXqcrpz3jXdDinGoINRK2VTG1G6wGhw1ZMMD267gD/bM /1A72fm7E7VGKeLWYKU9638Vp8k6upj83kxrGsV6RHrd0/eJNiQt8TCUB/R2kRA1yzaI sKlSxgcP3Q50ztvzRAlUzs9F7jGamihKJ3IE8J9BtbvXiR3bWVRAR8Zm65Y0PEH7xqOp R8Cg== X-Gm-Message-State: AOAM530auiN4yO31wbaps2KKXALuzUk0OQIHac+PRz8i3FDXn+i0dEkX MKPlaE41rExzTYSjtu6UThKD2Q== X-Google-Smtp-Source: ABdhPJxPmdErSMOhoryRCsrFlldDHXYfX1a9kCZoZFSw1Nl3rZvUiBkm+2erSEApdDPbwz3FhwX8Sg== X-Received: by 2002:a17:90b:38c4:: with SMTP id nn4mr2902960pjb.99.1625433157347; Sun, 04 Jul 2021 14:12:37 -0700 (PDT) Received: from rfd.leadboat.com ([2600:1702:a20:5750::46]) by smtp.gmail.com with ESMTPSA id k8sm10191445pfa.142.2021.07.04.14.12.36 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Sun, 04 Jul 2021 14:12:36 -0700 (PDT) Date: Sun, 4 Jul 2021 14:12:34 -0700 From: Noah Misch To: Tom Lane Cc: pgsql-hackers@lists.postgresql.org Subject: Re: "debug_invalidate_system_caches_always" is too long Message-ID: <20210704211234.GD2421985@rfd.leadboat.com> References: <1374320.1625430433@sss.pgh.pa.us> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1374320.1625430433@sss.pgh.pa.us> User-Agent: Mutt/1.5.24 (2015-08-30) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On Sun, Jul 04, 2021 at 04:27:13PM -0400, Tom Lane wrote: > As I've been poking around in this area, I find myself growing > increasingly annoyed at the new GUC name > "debug_invalidate_system_caches_always". It is too d*mn long. > It's a serious pain to type in any context where you don't have > autocomplete to help you. I've kept referring to this type of > testing as CLOBBER_CACHE_ALWAYS testing, even though that name is > now obsolete, just because it's so much shorter. I think we need > to reconsider this name while we still can. > > I do agree with the "debug_" prefix given that it's now visible to > users. However, it doesn't seem that hard to save some space in > the rest of the name. The word "system" is adding nothing of value, > and the word "always" seems rather confusing --- if it does > something "always", why is there more than one level? So a simple > proposal is to rename it to "debug_invalidate_caches". I agree with all that. The word "always" has been misinformation, given the multiple levels available. > However, I think we should also give serious consideration to > "debug_clobber_cache" or "debug_clobber_cache_always" for continuity > with past practice (though it still feels like "always" is a good > word to lose now). "debug_clobber_caches" is another reasonable > variant. https://en.wikipedia.org/wiki/Clobbering refers to cases where storage had no changes to its accessibility but now contains different data. That doesn't match InvalidateSystemCaches() especially well, so I think dropping that word has been a good step. Some other shorter terms could be debug_flush_caches, debug_rebuild_caches, or debug_expire_caches. (debug_caches is tempting, but that may ensnare folks looking for extra logging rather than a big slowdown.)