public inbox for [email protected]
help / color / mirror / Atom feedFrom: Jaime Casanova <[email protected]>
To: Richard Guo <[email protected]>
Cc: Ashutosh Bapat <[email protected]>
Cc: Anastasia Lubennikova <[email protected]>
Cc: Pg Hackers <[email protected]>
Cc: Richard Guo <[email protected]>
Cc: [email protected]
Subject: Re: A problem about partitionwise join
Date: Tue, 5 Oct 2021 12:19:22 -0500
Message-ID: <20211005171922.GB28628@ahch-to> (raw)
In-Reply-To: <CAMbWs48C0ux9mc+AS7D7DP6CyJxjQS=2mxQTpMJJKEeTua5wbQ@mail.gmail.com>
References: <CAN_9JTzo_2F5dKLqXVtDX5V6dwqB0Xk+ihstpKEt3a1LT6X78A@mail.gmail.com>
<CAMbWs4-zhLVU-uH42_N_v-LQF+VTGruVadQr6A_amhjmugB9-g@mail.gmail.com>
<160467632488.7362.12712548134124442813.pgcf@coridan.postgresql.org>
<CAMbWs49wRS5CkrjEOZxCVLO+Vm5YE_XHrYh8FCQbyvW-OUoMCg@mail.gmail.com>
<CAExHW5vx89LbqphcusNR3AJ+kihWXDo0gv7eJVu6+nsafwow-Q@mail.gmail.com>
<CAMbWs48C0ux9mc+AS7D7DP6CyJxjQS=2mxQTpMJJKEeTua5wbQ@mail.gmail.com>
On Wed, Jul 21, 2021 at 04:44:53PM +0800, Richard Guo wrote:
> On Fri, Nov 27, 2020 at 8:05 PM Ashutosh Bapat <[email protected]>
> wrote:
>
> >
> > In the example you gave earlier, the equi join on partition key was
> > there but it was replaced by individual constant assignment clauses.
> > So if we keep the original restrictclause in there with a new flag
> > indicating that it's redundant, have_partkey_equi_join will still be
> > able to use it without much change. Depending upon where all we need
> > to use avoid restrictclauses with the redundant flag, this might be an
> > easier approach. However, with Tom's idea partition-wise join may be
> > used even when there is no equi-join between partition keys but there
> > are clauses like pk = const for all tables involved and const is the
> > same for all such tables.
> >
>
> Correct. So with Tom's idea partition-wise join can cope with clauses
> such as 'foo.k1 = bar.k1 and foo.k2 = 16 and bar.k2 = 16'.
>
>
> >
> > In the spirit of small improvement made to the performance of
> > have_partkey_equi_join(), pk_has_clause should be renamed as
> > pk_known_equal and pks_known_equal as num_equal_pks.
> >
>
> Thanks for the suggestion. Will do that in the new version of patch.
>
Hi Richard,
We are marking this CF entry as "Returned with Feedback", which means
you are encouraged to send a new patch (and create a new entry for a
future CF for it) with the suggested changes.
--
Jaime Casanova
Director de Servicios Profesionales
SystemGuards - Consultores de PostgreSQL
view thread (32+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: A problem about partitionwise join
In-Reply-To: <20211005171922.GB28628@ahch-to>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox