Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1mseTX-0001MJ-Oc for pgsql-hackers@arkaria.postgresql.org; Thu, 02 Dec 2021 05:17:43 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1mseTW-0007UF-Ey for pgsql-hackers@arkaria.postgresql.org; Thu, 02 Dec 2021 05:17:42 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1mseTW-0007Tz-2s for pgsql-hackers@lists.postgresql.org; Thu, 02 Dec 2021 05:17:42 +0000 Received: from mail-il1-x136.google.com ([2607:f8b0:4864:20::136]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1mseTS-0007WV-Iv for pgsql-hackers@lists.postgresql.org; Thu, 02 Dec 2021 05:17:41 +0000 Received: by mail-il1-x136.google.com with SMTP id i6so27868909ila.0 for ; Wed, 01 Dec 2021 21:17:38 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=telsasoft-com.20210112.gappssmtp.com; s=20210112; h=date:from:to:cc:subject:message-id:references:mime-version :content-disposition:in-reply-to:user-agent; bh=u2BvDKfRxCVAKAT6LalfAkzsDBQcnRtjrehR5jIGs/E=; b=KnegGhG/x65JphMyAcm48cTLyTN+3eS5S4MmJtOyY7XTT/dkfyMwH5jyfpIrDvRsRF svs2xbPv4gbENcJSFj3V4WtHuk3XnUFhjjR33tXraPEjLPJGCWuq0mSvyQURVxeyIUDW L0AJdcdFipYe4GOwgHGtgJ4akCz8AxPaaselJXQ4UPtyQNUBQhNS8ut5a3jNUhxXMCMT 2m4gWId/R76y0X7vJIelVFiSqnytPoPvTqK9KyIw1CDAjmWK0hvu2SHth23/VTyRI+AJ N186iKL1ZZ+CfJB5qTg5Ixa4hB2x0xar2BeQFi0PQYpMiVenPKECD3/PzXhmO0OIvpjv DB5Q== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-disposition:in-reply-to:user-agent; bh=u2BvDKfRxCVAKAT6LalfAkzsDBQcnRtjrehR5jIGs/E=; b=mF20s1xjKdhX94v4RVwbcLvLBOmF+ojSZhMU91rHQeVoUfNOAvOE5y8qDbJbG6JkGx JvZsF0W4cnQEc2Ykvf+2HAvKvsynSRrifiQxl9oOWr4sXOl6PdO95CkfAl3p2L0WVw1h h+fyf688NBOPfHU1WfnX1v1AQSRsjgvG+iRhg33BTmPEyzkWlM0J8EMzf0yswX9GHPja VjrMt3YIiu9dDQn9exyW0qGkH9sCJTQe7zBYP6/wdU+p9WwLnE7+KbCvO6YFVrqyCzMD 1TDGu3bLdR8Klv+MAIr07uHwmozs/M/lrL+7UowqZsH+OLBNOKrYQU6MIl27nwLnM1On ckeA== X-Gm-Message-State: AOAM533iyHUlwNM74+VBvKdnHtCqmYUx3hpMefLhnrqfTlhGYr4WjNXT 7Zx5DXceE10sdRwayEtM3ZTaoPvnCbwOZg== X-Google-Smtp-Source: ABdhPJyFJoT0O+g1dse4DYK10/B3TK8QMF7SU0ssiYNhVV+Isgk6xNME7DQEZMQo+TCG8kUGSnCtXQ== X-Received: by 2002:a05:6e02:1a03:: with SMTP id s3mr13867054ild.309.1638422255995; Wed, 01 Dec 2021 21:17:35 -0800 (PST) Received: from pryzbyj.telsasoft (charmander.telsasoft.com. [50.244.222.1]) by smtp.gmail.com with ESMTPSA id h1sm1401548iow.31.2021.12.01.21.17.35 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Wed, 01 Dec 2021 21:17:35 -0800 (PST) Received: by pryzbyj.telsasoft (Postfix, from userid 1000) id C4F5A8009D6; Wed, 1 Dec 2021 23:17:34 -0600 (CST) Date: Wed, 1 Dec 2021 23:17:34 -0600 From: Justin Pryzby To: Michael Paquier Cc: pgsql-hackers@lists.postgresql.org Subject: Re: GUC flags Message-ID: <20211202051734.GN17618@telsasoft.com> References: <20211129030833.GJ17618@telsasoft.com> <20211201075904.GW17618@telsasoft.com> <20211202033439.GL17618@telsasoft.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.9.4 (2018-02-28) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On Thu, Dec 02, 2021 at 02:11:38PM +0900, Michael Paquier wrote: > On Wed, Dec 01, 2021 at 09:34:39PM -0600, Justin Pryzby wrote: > >> @@ -2762,7 +2763,8 @@ static struct config_int ConfigureNamesInt[] = > >> {"pre_auth_delay", PGC_SIGHUP, DEVELOPER_OPTIONS, > >> - gettext_noop("Waits N seconds on connection startup before authentication."), > >> + gettext_noop("Sets the amount of time to wait on connection " > >> + "startup before authentication."), > >> gettext_noop("This allows attaching a debugger to the process."), > > > > I wonder if these should say "Sets the amount of time to wait [before] > > authentication during connection startup" > > Hmm. I don't see much a difference between both of wordings in this > context. I find it easier to read "wait before authentication ..." than "wait ... before authentication". > > BTW the EXPLAIN flag for enable_incremental_sort could be backpatched to v13. > > This could cause small diffs in EXPLAIN outputs, which could be > surprising. This is not worth taking any risks. Only if one specifies explain(SETTINGS). It's fine either way ;) -- Justin