Subject: Re: [PATCH] Improve function toast_delete_external (src/backend/access/table/toast_helper.c)

From: Dong Wook Lee <[email-masked]>
Date: Wed, 9 Feb 2022 23:55:21 +0900

Oops, I realized that I made a mistake in my patch and now I have corrected it.

2022년 2월 9일 (수) 오후 11:33, Dong Wook Lee <[email-masked]>님이 작성:
>
> Hi,
>
> I've applied your patch. I think it's reasonable.
> but  IMHO It looks more complicated to read because of many conditions
> in if statement.
> so what about just moving up if-statement?
>
> Thanks.
> Dong Wook Lee
>
> 2022년 2월 9일 (수) 오후 7:56, Ranier Vilela <[email-masked]>님이 작성:
> >
> > Hi,
> >
> > I think this change can improve this particular function by avoiding touching value if not needed.
> > Test if not isnull is cheaper than test TupleDescAttr is -1.
> >
> > best regards,
> >
> > Ranier Vilela

---

From: Alvaro Herrera <[email-masked]>
Date: Wed, 9 Feb 2022 12:45:02 -0300

Our style is that we group all declarations in a block to appear at the
top.  We don't mix declarations and statements.

-- 
Álvaro Herrera           39°49'30"S 73°17'W  —  https://www.EnterpriseDB.com/