public inbox for [email protected]  
help / color / mirror / Atom feed
From: Kyotaro Horiguchi <[email protected]>
To: [email protected]
Cc: [email protected]
Cc: [email protected]
Subject: Re: Add CHECKPOINT_REQUESTED flag to the log message in LogCheckpointStart()
Date: Thu, 03 Mar 2022 09:39:37 +0900 (JST)
Message-ID: <[email protected]> (raw)
In-Reply-To: <CALj2ACV+zr=8-HJFBXazFGO+_0VXsTHXzB2EZEEiuDHs-hmDkQ@mail.gmail.com>
References: <CAMm1aWZRvUaU0KXbWNtOsNPUp1GJgJ2AL6p33p-_is+Cge_LfA@mail.gmail.com>
	<CALj2ACV+zr=8-HJFBXazFGO+_0VXsTHXzB2EZEEiuDHs-hmDkQ@mail.gmail.com>

At Wed, 2 Mar 2022 18:18:10 +0530, Bharath Rupireddy <[email protected]> wrote in 
> On Wed, Mar 2, 2022 at 5:41 PM Nitin Jadhav
> <[email protected]> wrote:
> >
> > Hi,
> >
> > I have noticed that the CHECKPOINT_REQUESTED flag information is not
> > present in the log message of LogCheckpointStart() function. I would
> > like to understand if it was missed or left intentionally. The log
> > message describes all the possible checkpoint flags except
> > CHECKPOINT_REQUESTED flag. I feel we should support this. Thoughts?
> 
> I don't think that's useful. Being in LogCheckpointStart
> (CreateCheckPoint or CreateRestartPoint) itself means that somebody
> has requested a checkpoint. Having CHECKPOINT_REQUESTED doesn't add
> any value.

Agreed.

> I would suggest removing the CHECKPOINT_REQUESTED flag as it's not
> being used anywhere instead CheckpointerShmem->ckpt_flags is used as
> an indication of the checkpoint requested in CheckpointerMain [1]. If

Actually no one does but RequestCheckpoint() accepts 0 as flags.
Checkpointer would be a bit more complex without CHECKPOINT_REQUESTED.
I don't think it does us any good to get rid of the flag value.

> others don't agree to remove as it doesn't cause any harm, then, I
> would  add something like this for more readability:

     if (((volatile CheckpointerShmemStruct *)
-          CheckpointerShmem)->ckpt_flags)
+          CheckpointerShmem)->ckpt_flags) & CHECKPOINT_REQUESTED))

I don't particularly object to this, but I don't think that change
makes the code significantly easier to read either.

regards.

-- 
Kyotaro Horiguchi
NTT Open Source Software Center






view thread (5+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected]
  Subject: Re: Add CHECKPOINT_REQUESTED flag to the log message in LogCheckpointStart()
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox