Subject: Re: [BUG] Panic due to incorrect missingContrecPtr after promotion

From: Michael Paquier <[email-masked]>
Date: Fri, 27 May 2022 08:53:03 +0900

On Tue, Feb 22, 2022 at 07:20:55PM +0000, Imseih (AWS), Sami wrote:
> The overwrite_contrecord was introduced in 13.5 with https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=ff9f111bce24.
> 
> Attached is a patch and a TAP test to handle this condition. The
> patch ensures that an overwrite_contrecord is only created if the
> missingContrecPtr is ahead of the last wal record.

The test you are introducing to force a complete segment to be filled
is funky, and kind of nice actually while being cheap.  This part
particularly makes the test predictable:
++unlink $node->basedir . "/pgdata/pg_wal/$endfile"
++  or die "could not unlink " . $node->basedir
. "/pgdata/pg_wal/$endfile: $!";

I really like that.

> With the patch, running the same tap test succeeds and a PANIC is
> not observed.

This needs a very close lookup, I'll try to check all that except if
somebody beats me to it.
--
Michael

---

From: Michael Paquier <[email-masked]>
Date: Fri, 27 May 2022 09:03:30 +0900

> This needs a very close lookup, I'll try to check all that except if

Please ignore that..  I need more coffee, and likely a break.
--
Michael