Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1pKEZL-0004Np-Ac for pgsql-hackers@arkaria.postgresql.org; Tue, 24 Jan 2023 08:22:15 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1pKEZI-0002IK-9k for pgsql-hackers@arkaria.postgresql.org; Tue, 24 Jan 2023 08:22:12 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1pKEZH-0002IA-UN for pgsql-hackers@lists.postgresql.org; Tue, 24 Jan 2023 08:22:12 +0000 Received: from mail-pl1-x630.google.com ([2607:f8b0:4864:20::630]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1pKEZG-0002xZ-E6 for pgsql-hackers@postgresql.org; Tue, 24 Jan 2023 08:22:11 +0000 Received: by mail-pl1-x630.google.com with SMTP id 5so8706997plo.3 for ; Tue, 24 Jan 2023 00:22:10 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20210112; h=content-transfer-encoding:mime-version:user-agent:references :in-reply-to:from:subject:cc:to:message-id:date:from:to:cc:subject :date:message-id:reply-to; bh=4MN4Uqz587U9f+cv6qW1Il8atojojAKxZ2Rdlkuiw0U=; b=P+NwJPSswkVRbaLbM0UbZnv1sXPlvuo/ljcga4J1ePfMDu/Xr0VlvXYW5T0oXxDcme KMydTtzAT+jg+VsJDfg+TDYcdxC7MB3SS0Ht91E26XBt5TVjrvfFqVWoUB2HAefReoCi nwVE8gkTrZZ3+cyK8vL2HYJF3pKhrbpbhLdW9Z0qv5cQMhOgydTPLprE0xFXRSgzvy1d LAjZCrGrwc0BG4NvYzNiFMQnbG/e+LGy0QSlM85rsE3bn9G29tzFZ4bcJ0kvAlFCGyjM uMs3aOUfzHcWB11ji1Ks0uzOWhmWt87DdvVNLpsxGKqWijk7c1a2iUpsQKtinS9LBa/1 4g7w== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=content-transfer-encoding:mime-version:user-agent:references :in-reply-to:from:subject:cc:to:message-id:date:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=4MN4Uqz587U9f+cv6qW1Il8atojojAKxZ2Rdlkuiw0U=; b=eDX2B4mMNWkIm8ADN/leX35MXAeehn9Txbbo2MWtzWvRARuGKl9L5pq5gnoHYc3HWO 4Qcia4dKyxp/c7HQlbp4X2YpsL2JkxKs+70J4MFKq07NbAagNV8UZUSN8rVydz1aiSOF INZLJWboLO8VWf/mqsIYfC9uW26shCrsZwAkTebsAvY8oruW/1IhUEVwyMyUKPR3GEPy tcqbfFyGAwyLk7regfpUXlZISRR3kJAfCE82s4IZcIEs/ji9NlxpMuPQd4645nYrw2DA va5yGaurVvnlSYvKIwxzET06qzsUShxt8anC/ZVHKviFLs7Jq+jZC4sJFeOVo5Lnp79K otbw== X-Gm-Message-State: AFqh2kpMwUXxdHHAz0UFOdYwEOm9ps0ky3ipkOOv+GrkxeNjf6XE+JuI WgQBdX38lyEmLRfTg5ju0y4= X-Google-Smtp-Source: AMrXdXvP1FbBo+0PbPdvs8K59vYKSd7pjBNgUVBK0c1eAGhctlUPU7NEvOs5p5Cgryq8WxwYiRiTpg== X-Received: by 2002:a05:6a20:6d02:b0:b6:9f9f:4b90 with SMTP id fv2-20020a056a206d0200b000b69f9f4b90mr44442897pzb.24.1674548528392; Tue, 24 Jan 2023 00:22:08 -0800 (PST) Received: from localhost (KD036014041111.ppp-bb.dion.ne.jp. [36.14.41.111]) by smtp.gmail.com with ESMTPSA id bg5-20020a1709028e8500b0019460c34839sm1037306plb.185.2023.01.24.00.22.05 (version=TLS1_3 cipher=TLS_CHACHA20_POLY1305_SHA256 bits=256/256); Tue, 24 Jan 2023 00:22:07 -0800 (PST) Date: Tue, 24 Jan 2023 17:22:03 +0900 (JST) Message-Id: <20230124.172203.448918351330829200.horikyota.ntt@gmail.com> To: melanieplageman@gmail.com Cc: vignesh21@gmail.com, andres@anarazel.de, pryzby@telsasoft.com, lukas@fittl.com, alvherre@alvh.no-ip.org, magnus@hagander.net, pgsql-hackers@postgresql.org, thomas.munro@gmail.com, m.sakrejda@gmail.com Subject: Re: pg_stat_bgwriter.buffers_backend is pretty meaningless (and more?) From: Kyotaro Horiguchi In-Reply-To: References: User-Agent: Mew version 6.8 on Emacs 26.1 Mime-Version: 1.0 Content-Type: Text/Plain; charset=us-ascii Content-Transfer-Encoding: 7bit List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Hello. At Thu, 19 Jan 2023 21:15:34 -0500, Melanie Plageman wrote in > Oh dear-- an extra FlushBuffer() snuck in there somehow. > Removed it in attached v51. > Also, I fixed an issue in my tablespace.sql updates I only looked 0002 and 0004. (Sorry for the random order of the comment..) 0002: + Assert(pgstat_bktype_io_stats_valid(bktype_shstats, MyBackendType)); This is relatively complex checking. We already asserts-out increments of invalid counters. Thus this is checking if some unrelated codes clobbered them, which we do only when consistency is critical. Is there any needs to do that here? I saw another occurance of the same assertion. -/* Reset some shared cluster-wide counters */ +/* + * Reset some shared cluster-wide counters + * + * When adding a new reset target, ideally the name should match that in + * pgstat_kind_infos, if relevant. + */ I'm not sure the addition is useful.. +pgstat_count_io_op(IOObject io_object, IOContext io_context, IOOp io_op) +{ + Assert(io_object < IOOBJECT_NUM_TYPES); + Assert(io_context < IOCONTEXT_NUM_TYPES); + Assert(io_op < IOOP_NUM_TYPES); + Assert(pgstat_tracks_io_op(MyBackendType, io_object, io_context, io_op)); Is there any reason for not checking the value ranges at the bottom-most functions? They can lead to out-of-bounds access so I don't think we need to continue execution for such invalid values. + no_temp_rel = bktype == B_AUTOVAC_LAUNCHER || bktype == B_BG_WRITER || + bktype == B_CHECKPOINTER || bktype == B_AUTOVAC_WORKER || + bktype == B_STANDALONE_BACKEND || bktype == B_STARTUP; I'm not sure I like to omit parentheses for such a long Boolean expression on the right side. + write_chunk_s(fpout, &pgStatLocal.snapshot.io); + if (!read_chunk_s(fpin, &shmem->io.stats)) The names of the functions hardly make sense alone to me. How about write_struct()/read_struct()? (I personally prefer to use write_chunk() directly..) + PgStat_BktypeIO This patch abbreviates "backend" as "bk" but "be" is used in many places. I think that naming should follow the predecessors. 0004: system_views.sql: +FROM pg_stat_get_io() b; What does the "b" stand for? (Backend? then "s" or "i" seems straight-forward.) + nulls[col_idx] = !pgstat_tracks_io_op(bktype, io_obj, io_context, io_op); + + if (nulls[col_idx]) + continue; + + values[col_idx] = + Int64GetDatum(bktype_stats->data[io_obj][io_context][io_op]); This is a bit hard to read since it requires to follow the condition flow. The following is simpler and I thhink close to our standard. if (pgstat_tacks_io_op()) values[col_idx] = Int64GetDatum(bktype_stats->data[io_obj][io_context][io_op]); else nulls[col_idx] = true; > + Number of read operations in units of op_bytes. I may be the only one who see the name as umbiguous between "total number of handled bytes" and "bytes hadled at an operation". Can't it be op_blocksize or just block_size? + b.io_object, + b.io_context, It's uncertain to me why only the two columns are prefixed by "io". Don't "object_type" and just "context" work instead? regards. -- Kyotaro Horiguchi NTT Open Source Software Center