Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1pKkLS-0000Et-JA for pgsql-hackers@arkaria.postgresql.org; Wed, 25 Jan 2023 18:18:02 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1pKkLR-0003Ly-3v for pgsql-hackers@arkaria.postgresql.org; Wed, 25 Jan 2023 18:18:01 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1pKkLQ-0003Iu-OT for pgsql-hackers@lists.postgresql.org; Wed, 25 Jan 2023 18:18:00 +0000 Received: from mail-pl1-x636.google.com ([2607:f8b0:4864:20::636]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim 4.92) (envelope-from ) id 1pKkLK-00064o-2j for pgsql-hackers@postgresql.org; Wed, 25 Jan 2023 18:18:00 +0000 Received: by mail-pl1-x636.google.com with SMTP id c6so18684769pls.4 for ; Wed, 25 Jan 2023 10:17:53 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20210112; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:from:to:cc:subject:date:message-id:reply-to; bh=MmIEHgUFBsqIZsSaxgQTNYZcRm9ZMkMuZwC1nOy5uPk=; b=qOjAlIDsiA133sz74XHE0t5Syentb35i8Eye0Xd+Vt+59rOCEN56yBZxUp2/keeLot skN9qWXh8yfrknE0yZPzL6L0Rav5t4azFCRCJV4z3rStIIudIX3at5fhlNMVDZ6RoYUO o0CM50bJfq8gt5Z/8HyX+JDBh2Eu6ej4typhqsRPef3ho7Plxvp3YiUE1JLqAJ84yrf1 STUHLTlBG7OUVPbUikwIfl8HOaNg7HePqEZJV+DMGAYE43/Fp7BPzMvk+aZz18sqgNtM nXVp7u8jMKJaaLVyCWf4h6ARuniAqL1MtYOAUl/sUgzrACGITBwfLm5eC1qtPuaCpdJm wjIw== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:x-gm-message-state:from:to:cc:subject:date :message-id:reply-to; bh=MmIEHgUFBsqIZsSaxgQTNYZcRm9ZMkMuZwC1nOy5uPk=; b=0TLBNOLbJlpNfQJZqjebqRxdXAAbNCfdbejRwHFOKRKwteGdSJDny2I6mYid9odDJX mmFUg6H1N7/s8qYLf12/PVQHDY36Z56RMOE8SUIZGu3+yhOGFKSB1hg+AOqXEhaGYSB8 GXFRmMfMk4/sfn202OviKmWZX9y5HqogMo/rakDFWOQsjhYFOn9s0QZeRcgGcAms2pix FJGIOLLlQjOdrBp8scvYoa4Tftdnv7bqVq1rB0AfLL2az++tpIPWWBupbMmrFsZ3ttuO B1Aegbpz+xNBsa4kJRNH3PHPUmZJVjkzsNY9iKs38t1z+/kUHFoqhkibve8c7SMv2cO/ 3J2A== X-Gm-Message-State: AO0yUKVUFV9NKYUynZJAWKfYGvW1A6u+g2kv5i6kK9rzbCQk3G7EPjxO pRX9DGnu8ihSpXouNUe4jov0rH6pOyA= X-Google-Smtp-Source: AK7set+0NP+KxTVOOGHU+5xvc3uFkvmjYSMPs5S+vjvFzCxsfnRd2A6AZIbZtEL4mIKIagi0rtASeA== X-Received: by 2002:a17:902:c60b:b0:196:12de:2810 with SMTP id r11-20020a170902c60b00b0019612de2810mr5916301plr.10.1674670672139; Wed, 25 Jan 2023 10:17:52 -0800 (PST) Received: from nathanxps13 ([50.47.162.83]) by smtp.gmail.com with ESMTPSA id k15-20020aa790cf000000b00587ca71704dsm3941403pfk.37.2023.01.25.10.17.51 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Wed, 25 Jan 2023 10:17:51 -0800 (PST) Date: Wed, 25 Jan 2023 10:17:50 -0800 From: Nathan Bossart To: Robert Haas Cc: Michael Paquier , "pgsql-hackers@postgresql.org" Subject: Re: pgsql: Rename contrib module basic_archive to basic_wal_module Message-ID: <20230125181750.GC1098626@nathanxps13> References: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On Wed, Jan 25, 2023 at 12:49:45PM -0500, Robert Haas wrote: > On Wed, Jan 25, 2023 at 12:37 AM Michael Paquier wrote: >> Rename contrib module basic_archive to basic_wal_module > > FWIW, I find this new name much less clear than the old one. > > If we want to provide a basic_archive module and a basic_recovery > module, that seems fine. Why merge them? I'll admit I've been stewing on whether "WAL Modules" is the right name. My first instinct was to simply call it "Archive and Recovery Modules," which is longer but (IMHO) clearer. I wanted to merge basic_archive and basic_recovery because there's a decent chunk of duplicated code. Perhaps that is okay, but I would rather just have one test module. AFAICT the biggest reason to split it is because we can't determine a good name. Maybe we could leave the name as "basic_archive" since it deals with creating and recovering archive files. -- Nathan Bossart Amazon Web Services: https://aws.amazon.com