Subject: Re: Remove MSVC scripts from the tree

From: NINGWEI CHEN <[email-masked]>
Date: Tue, 26 Sep 2023 14:25:12 +0900

On Fri, 22 Sep 2023 10:12:29 +0900
Michael Paquier <[email-masked]> wrote:

> As of today, I can see that the only buildfarm members relying on
> these scripts are bowerbird and hamerkop, so these two would fail if
> the patch attached were to be applied today.  I am adding Andrew
> D. and the maintainers of hamerkop (SRA-OSS) in CC for comments.

hamerkop is not yet prepared for Meson builds, but we plan to work on this support soon. 
If we go with Meson builds exclusively right now, we will have to temporarily remove the master/HEAD for a while.

Best Regards.
-- 
SRA OSS LLC
Chen Ningwei<[email-masked]>

---

From: Andrew Dunstan <[email-masked]>
Date: Tue, 26 Sep 2023 12:17:04 -0400

On 2023-09-26 Tu 01:25, NINGWEI CHEN wrote:
> Michael Paquier<[email-masked]>  wrote:
>

I don't think we should switch to that until you're ready.

cheers

andrew

--
Andrew Dunstan
EDB:https://www.enterprisedb.com

---

From: Michael Paquier <[email-masked]>
Date: Mon, 4 Dec 2023 17:05:24 +0900

> I don't think we should switch to that until you're ready.

Agreed that it would just be breaking a build for the sake of breaking
it.  Saying that, the last exchange that we had about hamerkop
switching to meson was two months ago.  Are there any plans to do the
switch?
--
Michael

---

From: Andrew Dunstan <[email-masked]>
Date: Mon, 4 Dec 2023 15:11:47 -0500

> switching to meson was two months ago.  Are there any plans to do the

I just had a look at shifting bowerbird to use meson, and it got stymied 
at the c99 test, which apparently doesn't compile with anything less 
than VS2019.

I can upgrade bowerbird, but that will take rather longer. It looks like 
hamerkop is in th4e same boat.

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com

---

From: Andres Freund <[email-masked]>
Date: Thu, 7 Dec 2023 09:05:13 -0800

Hi,

On 2023-12-04 15:11:47 -0500, Andrew Dunstan wrote:
> I just had a look at shifting bowerbird to use meson, and it got stymied at
> the c99 test, which apparently doesn't compile with anything less than
> VS2019.

What error or warning is being raised by msvc?

Andres