Subject: Remove dead code in pg_ctl.c

From: David Steele <[email-masked]>
Date: Wed, 25 Oct 2023 14:53:31 -0400

Hackers,

It looks like this code was missed in 39969e2a when exclusive backup was 
removed.

Regards,
-David

diff --git a/src/bin/pg_ctl/pg_ctl.c b/src/bin/pg_ctl/pg_ctl.c
index 807d7023a99..4099d240e03 100644
--- a/src/bin/pg_ctl/pg_ctl.c
+++ b/src/bin/pg_ctl/pg_ctl.c
@@ -96,7 +96,6 @@ static time_t start_time;
 static char postopts_file[MAXPGPATH];
 static char version_file[MAXPGPATH];
 static char pid_file[MAXPGPATH];
-static char backup_file[MAXPGPATH];
 static char promote_file[MAXPGPATH];
 static char logrotate_file[MAXPGPATH];
 
@@ -2447,7 +2446,6 @@ main(int argc, char **argv)
 		snprintf(postopts_file, MAXPGPATH, "%s/postmaster.opts", pg_data);
 		snprintf(version_file, MAXPGPATH, "%s/PG_VERSION", pg_data);
 		snprintf(pid_file, MAXPGPATH, "%s/postmaster.pid", pg_data);
-		snprintf(backup_file, MAXPGPATH, "%s/backup_label", pg_data);
 
 		/*
 		 * Set mask based on PGDATA permissions,

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 25 Oct 2023 15:02:01 -0500

> It looks like this code was missed in 39969e2a when exclusive backup was

Indeed.  I'll plan on committing this shortly.

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com