Subject: Re: Unchecked strdup leading to segfault in pg_dump

From: "Tristan Partin" <[email-masked]>
Date: Wed, 20 Dec 2023 09:39:55 -0600

On Wed Dec 20, 2023 at 8:52 AM CST, Daniel Gustafsson wrote:
> While looking at something else I noticed that pg_dump performs strdup without
> checking the returned pointer, which will segfault in hasSuffix() in case of
> OOM.  The attached, which should be backpatched to 16, changes to using
> pg_strdup instead which handles it.

Looks good to me.

-- 
Tristan Partin
Neon (https://neon.tech)

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 20 Dec 2023 10:20:26 -0600

>> pg_strdup instead which handles it.

+1

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com