Subject: Re: Psql meta-command conninfo+

From: Hunaid Sohail <[email-masked]>
Date: Sat, 14 Sep 2024 17:28:39 +0500

Hi Jim,

On Fri, Sep 13, 2024 at 4:27 PM Jim Jones <[email-masked]> wrote:

> I just noticed that messages' order has been slightly changed. The
> message "You are connected to database "postgres" as user "hunaid" via
> socket in "/tmp" at port "5430" used to be printed after the table, and
> now it is printed before.
>
> $ /usr/local/postgres-dev/bin/psql -x "\
>     hostaddr=0
>     user=jim dbname=postgres
>     port=54322" -c "\conninfo+"
>
> You are connected to database "postgres" as user "jim" on host "0"
> (address "0.0.0.0") at port "54322".
> Connection Information
> -[ RECORD 1 ]--------+--------
> Protocol Version     | 3
> SSL Connection       | no
> GSSAPI Authenticated | no
> Client Encoding      | UTF8
> Server Encoding      | UTF8
> Session User         | jim
> Backend PID          | 2419033
>
> It is IMHO a little strange because the "SSL connection" info keeps
> being printed in the end. I would personally prefer if they're printed
> together --- preferably after the table. But I'm not sure if there's any
> convention for that.
>

I agree that both messages should be printed together. IMO the message
"You are connected to database..." should be printed at the top, no?
Because it shows important info that the user may be interested to see
first. Then we can combine the ssl message.

postgres=# \x
Expanded display is on.
postgres=# \conninfo+
You are connected to database "postgres" as user "hunaid" on host
"localhost" (address "127.0.0.1") at port "5430".
SSL connection (protocol: TLSv1.3, cipher: TLS_AES_256_GCM_SHA384,
compression: off, ALPN: postgresql)
Connection Information
-[ RECORD 1 ]--------+-------
Protocol Version     | 3
SSL Connection       | yes
GSSAPI Authenticated | no
Client Encoding      | UTF8
Server Encoding      | UTF8
Session User         | hunaid
Backend PID          | 109092

> Also, there are a few compilation warnings regarding const qualifiers:
>

Noted. I will fix them in the next patch.

Regards,
Hunaid Sohail

---

From: Alvaro Herrera <[email-masked]>
Date: Sat, 14 Sep 2024 19:37:11 +0200

> GSSAPI Authenticated | no

I don't understand why this is is printing half the information in
free-form plain text and the other half in tabular format.  All these
items that you have in the free-form text lines should be part of the
table, I think.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
#error "Operator lives in the wrong universe"
  ("Use of cookies in real-time system development", M. Gleixner, M. Mc Guire)