Subject: Re: Drop back the redundant "Lock" suffix from LWLock wait event names

From: Alvaro Herrera <[email-masked]>
Date: Mon, 2 Dec 2024 14:22:49 +0100

On 2024-Dec-02, Bertrand Drouvot wrote:

> Hi hackers,
> 
> da952b415f unintentionally added back the "Lock" suffix into the LWLock wait
> event names:
> 
> - "added back" because the "Lock" suffix was removed in 14a9101091
> - "unintentionally" because there is nothing in the thread [2] that explicitly
> mentions that the idea was also to revert 14a9101091

Oh, you're right, this was unintentional and unnoticed.  I'll push this
shortly, to both 17 and master.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/

---

From: Alvaro Herrera <[email-masked]>
Date: Tue, 3 Dec 2024 16:01:41 +0100

> shortly, to both 17 and master.

Pushed, thanks Christophe and Bertrand.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/
<Schwern> It does it in a really, really complicated way
<crab> why does it need to be complicated?
<Schwern> Because it's MakeMaker.