Subject: Re: Proposal for enabling auto-vectorization for checksum calculations

From: [email-masked]
Date: Thu, 11 Sep 2025 06:21:26 +0000

Hi John,

Thanks for the feedback. This is v5 of the patchset, updated following your comments:

- Moved the function pointer definitions out of common headers and
  into src/port, consistent with existing practice.

Thanks again for the guidance.

Best regards,
Kim Andrew

---

From: Andrew Kim <[email-masked]>
Date: Tue, 16 Sep 2025 18:10:56 -0700

> I don't know if this is related to the crashes, but it doesn't seem
> like a good idea to #include the function pointer stuff everywhere,
> that should probably go into src/port like the others.
Just a gentle reminder on this patch series — I’ve already rebased it on
the latest tip of master and addressed the earlier review comments:

  * Moved the function pointer definitions into src/port as suggested.
  * Rebased cleanly on the current master branch.

Could someone take another look and share any further feedback?

Thanks a lot for your time and review,
Andrew Kim