Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jnNdb-0000Ya-CY for pgsql-hackers@arkaria.postgresql.org; Mon, 22 Jun 2020 14:41:31 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1jnNda-0001py-8G for pgsql-hackers@arkaria.postgresql.org; Mon, 22 Jun 2020 14:41:30 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jnNda-0001pr-1Q for pgsql-hackers@lists.postgresql.org; Mon, 22 Jun 2020 14:41:30 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jnNdS-0004JE-Nk for pgsql-hackers@postgresql.org; Mon, 22 Jun 2020 14:41:29 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 05MEfHtO2037458; Mon, 22 Jun 2020 10:41:18 -0400 From: Tom Lane To: Robert Haas cc: Tomas Vondra , Julien Rouhaud , Peter Eisentraut , pgsql-hackers Subject: Re: suggest to rename enable_incrementalsort In-reply-to: References: <20200621112159.qtgedtrqw2c47pm4@development> Comments: In-reply-to Robert Haas message dated "Mon, 22 Jun 2020 10:16:54 -0400" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <2037456.1592836877.1@sss.pgh.pa.us> Date: Mon, 22 Jun 2020 10:41:17 -0400 Message-ID: <2037457.1592836877@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Robert Haas writes: > On Sun, Jun 21, 2020 at 7:22 AM Tomas Vondra > wrote: >> The reason why I kept the single-word variant is consistency with other >> GUCs that affect planning, like enable_indexscan, enable_hashjoin and >> many others. > Right, so that makes sense, but from a larger point of view, how much > sense does it actually make? Maybe I'm just used to the names, but I find that things like "enable_seqscan" and "enable_nestloop" are pretty readable. Once they get longer, though, not so much. So I agree with renaming enable_incrementalsort. > So I'm +1 for changing this, and I'd definitely be +1 for renaming the > others if they weren't released already, and at least +0.5 for it > anyhow. Nah. Those names are way too well entrenched. Besides which, if we open them up for reconsideration, there's going to be a lot of bikeshedding done. Should "enable_seqscan" become "enable_seq_scan", or "enable_sequential_scan", or maybe "enable_scan_sequential"? Why doesn't "enable_nestloop" contain the word "join"? Etc etc. (I do have to wonder if maybe this one should be enable_sort_incremental.) regards, tom lane