Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gJ0q0-0002lY-5g for pgsql-hackers@arkaria.postgresql.org; Sat, 03 Nov 2018 18:40:00 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1gJ0py-0005vy-0Q for pgsql-hackers@arkaria.postgresql.org; Sat, 03 Nov 2018 18:39:58 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gJ0px-0005vr-LM for pgsql-hackers@lists.postgresql.org; Sat, 03 Nov 2018 18:39:57 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gJ0pr-0004ma-0f for pgsql-hackers@postgresql.org; Sat, 03 Nov 2018 18:39:56 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id wA3IdjZ5021252; Sat, 3 Nov 2018 14:39:45 -0400 From: Tom Lane To: Andres Freund cc: Pavel Raiskup , PostgreSQL Hacker , devrim@gunduz.org Subject: Re: plruby: rb_iterate symbol clash with libruby.so In-reply-to: <20181103183040.jj7gp2zszusnea2d@alap3.anarazel.de> References: <4738198.8KVIIDhgEB@nb.usersys.redhat.com> <20461.1541269186@sss.pgh.pa.us> <20181103183040.jj7gp2zszusnea2d@alap3.anarazel.de> Comments: In-reply-to Andres Freund message dated "Sat, 03 Nov 2018 11:30:40 -0700" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <21250.1541270385.1@sss.pgh.pa.us> Date: Sat, 03 Nov 2018 14:39:45 -0400 Message-ID: <21251.1541270385@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Andres Freund writes: >> Pavel Raiskup writes: >>> Is it realistic we could rename red-black tree methods from 'rb_*' to e.g. >>> 'rbt_*' to avoid this clash? > ISTM this specific case we could solve the issue by opening plruby.so / > extension sos with RTLD_DEEPBIND. That doesn't work if ruby extensions > that are loaded later use rb_iterate, but should work for the case above. Doesn't work on non-glibc platforms, though. > On 2018-11-03 14:19:46 -0400, Tom Lane wrote: >> That's not terribly appetizing, because it essentially means we're giving >> Ruby (and potentially every other library on the planet) veto power over >> our function namespace. That does not scale, especially not when the >> feedback loop has a time constant measured in years :-( >> I don't have a huge objection to renaming the rbtree functions, other >> than the precedent it sets ... > I don't mind the precedent that much, but isn't that also not unlikely > to break other extensions that use those functions? I rather doubt there are any. Also, if there are, the RTLD_DEEPBIND solution would break them too, no? regards, tom lane