Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hEdak-0007pt-Kd for pgsql-hackers@arkaria.postgresql.org; Thu, 11 Apr 2019 17:34:26 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1hEdaj-0001k5-AB for pgsql-hackers@arkaria.postgresql.org; Thu, 11 Apr 2019 17:34:25 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hEdaj-0001jv-1c for pgsql-hackers@lists.postgresql.org; Thu, 11 Apr 2019 17:34:25 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1hEdag-0003DB-V3 for pgsql-hackers@postgresql.org; Thu, 11 Apr 2019 17:34:24 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id x3BHXsku021772; Thu, 11 Apr 2019 13:33:54 -0400 From: Tom Lane To: Andres Freund cc: Heikki Linnakangas , Justin Pryzby , Haribabu Kommi , Kyotaro HORIGUCHI , Alvaro Herrera , David Rowley , Robert Haas , Asim R P , pgsql-hackers@postgresql.org, Ashwin Agrawal , Dmitry Dolgov <9erthalion6@gmail.com>, Alexander Korotkov Subject: Re: Pluggable Storage - Andres's take In-reply-to: <20190411164947.nkii4gaeilt4bui7@alap3.anarazel.de> References: <20190401231810.arpvmhw66bwsyobj@alap3.anarazel.de> <20190402005352.64hk76gddvs36uwl@alap3.anarazel.de> <20190402215743.cfiwzlk2szwq4jp3@alap3.anarazel.de> <20190404055138.GA24864@telsasoft.com> <20190405165101.mosiflz6slokm2oo@alap3.anarazel.de> <9a7fb9cc-2419-5db7-8840-ddc10c93f122@iki.fi> <20190408173723.wnfni5t3g7ia7jit@alap3.anarazel.de> <9ed6bdab-0ce9-8c1a-8b84-838d4316ef35@iki.fi> <20190411164947.nkii4gaeilt4bui7@alap3.anarazel.de> Comments: In-reply-to Andres Freund message dated "Thu, 11 Apr 2019 09:49:47 -0700" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <21770.1555004034.1@sss.pgh.pa.us> Content-Transfer-Encoding: quoted-printable Date: Thu, 11 Apr 2019 13:33:54 -0400 Message-ID: <21771.1555004034@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Andres Freund writes: > On 2019-04-11 14:52:40 +0300, Heikki Linnakangas wrote: >> + * HEIKKI: A flags bitmask argument would be more readable than 6 boo= leans > I honestly don't have strong feelings about it. Not sure that I buy that > bitmasks would be much more readable Sure they would be --- how's FLAG_FOR_FOO | FLAG_FOR_BAR not better than unlabeled "true" and "false"? > - but perhaps we could just use the > struct trickery we started to use in I find that rather ugly really. If we're doing something other than a dozen-or-so booleans, maybe its the only viable option. But for cases where a flags argument will serve, that's our longstanding practice and I don't see a reason to deviate. regards, tom lane