Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1r2xX2-001YyX-Sc for pgsql-hackers@arkaria.postgresql.org; Tue, 14 Nov 2023 17:49:00 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1r2xX1-009xQi-4V for pgsql-hackers@arkaria.postgresql.org; Tue, 14 Nov 2023 17:48:59 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1r2xX0-009xQa-Qw for pgsql-hackers@lists.postgresql.org; Tue, 14 Nov 2023 17:48:58 +0000 Received: from sss.pgh.pa.us ([68.162.161.243]) by makus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1r2xWy-005ZTe-D1 for pgsql-hackers@lists.postgresql.org; Tue, 14 Nov 2023 17:48:57 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 3AEHmsJJ2502480; Tue, 14 Nov 2023 12:48:55 -0500 From: Tom Lane To: Aleksander Alekseev cc: pgsql-hackers@lists.postgresql.org, James Keener Subject: Re: BUG #18097: Immutable expression not allowed in generated at In-reply-to: References: <18097-ebb179674f22932f@postgresql.org> <118FF128-C9CA-490C-8E67-65888EE8283F@jimkeener.com> <1887197.1694189299@sss.pgh.pa.us> <2250243.1694287087@sss.pgh.pa.us> <2275069.1694300202@sss.pgh.pa.us> Comments: In-reply-to Aleksander Alekseev message dated "Tue, 14 Nov 2023 15:10:05 +0300" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <2502478.1699984134.1@sss.pgh.pa.us> Date: Tue, 14 Nov 2023 12:48:54 -0500 Message-ID: <2502479.1699984134@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Aleksander Alekseev writes: >> There are a couple of points worth bikeshedding perhaps. I didn't >> spend much thought on the wrapper functions' names, but it's surely >> true that the semantic difference between contain_mutable_functions >> and ContainMutableFunctions is quite un-apparent from those names. >> Anybody got a better idea? > Oh no! We encountered one of the most difficult problems in computer > science [1]. Indeed :-(. Looking at it again this morning, I'm thinking of using "contain_mutable_functions_after_planning" --- what do you think of that? regards, tom lane