Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1k3sN2-0005Yk-Sw for pgsql-hackers@arkaria.postgresql.org; Fri, 07 Aug 2020 02:44:36 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1k3sN1-0007EG-RP for pgsql-hackers@arkaria.postgresql.org; Fri, 07 Aug 2020 02:44:35 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1k3sN1-0007De-KN for pgsql-hackers@lists.postgresql.org; Fri, 07 Aug 2020 02:44:35 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1k3sMy-0000P9-Uw for pgsql-hackers@postgresql.org; Fri, 07 Aug 2020 02:44:34 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 0772iUZn2715414; Thu, 6 Aug 2020 22:44:30 -0400 From: Tom Lane To: Andy Fan cc: Robert Haas , Amit Langote , Justin Pryzby , "pgsql-hackers@postgresql.org" Subject: Re: FailedAssertion("pd_idx == pinfo->nparts", File: "execPartition.c", Line: 1689) In-reply-to: References: <20200802181131.GA27754@telsasoft.com> <20200803161133.GA21372@telsasoft.com> <2528807.1596648630@sss.pgh.pa.us> <2550497.1596651719@sss.pgh.pa.us> <2598266.1596686548@sss.pgh.pa.us> <2626504.1596724930@sss.pgh.pa.us> <2685059.1596760353@sss.pgh.pa.us> Comments: In-reply-to Andy Fan message dated "Fri, 07 Aug 2020 10:26:21 +0800" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <2715412.1596768270.1@sss.pgh.pa.us> Date: Thu, 06 Aug 2020 22:44:30 -0400 Message-ID: <2715413.1596768270@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Andy Fan writes: > I am not sure if we need to limit the scope to "between parsing and > execution", Yeah, there might be reason to add similar functionality in other places later. I'm not sure where yet --- but that idea does make me slightly unhappy with the "delay_execution" moniker. I don't have a better name though ... regards, tom lane