Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gK65W-0007p8-TX for pgsql-hackers@arkaria.postgresql.org; Tue, 06 Nov 2018 18:28:31 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1gK65V-0002pq-82 for pgsql-hackers@arkaria.postgresql.org; Tue, 06 Nov 2018 18:28:29 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gK65V-0002ph-17 for pgsql-hackers@lists.postgresql.org; Tue, 06 Nov 2018 18:28:29 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gK65Q-0005aB-MW for pgsql-hackers@postgresql.org; Tue, 06 Nov 2018 18:28:26 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id wA6ISLTO028763; Tue, 6 Nov 2018 13:28:21 -0500 From: Tom Lane To: Pavel Raiskup cc: Robert Haas , "pgsql-hackers@postgresql.org" , Devrim =?ISO-8859-1?Q?G=DCND=DCZ?= Subject: Re: plruby: rb_iterate symbol clash with libruby.so In-reply-to: <22881.1541515786@sss.pgh.pa.us> References: <4738198.8KVIIDhgEB@nb.usersys.redhat.com> <20461.1541269186@sss.pgh.pa.us> <1772202.Bn4MKCBuZf@nb.usersys.redhat.com> <22881.1541515786@sss.pgh.pa.us> Comments: In-reply-to Tom Lane message dated "Tue, 06 Nov 2018 09:49:46 -0500" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <28761.1541528901.1@sss.pgh.pa.us> Date: Tue, 06 Nov 2018 13:28:21 -0500 Message-ID: <28762.1541528901@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk I wrote: > Yeah. The long and short of this is that we're trampling on namespace > that reasonably belongs to Ruby --- if they had some functions named > "pg_something" and complained about a collision with libpq, would we > change? Nope. So really we should rename these. > Barring objections I'll go make this happen shortly. Done. I realized that the immediate problem, rb_iterate(), was only added as of PG v10, which may explain why we hadn't heard complaints about this till now. So I've made the change only as far back as v10. In principle we could change the rbtree code in 9.5/9.6 as well, but I think that's more likely to create problems than fix any. regards, tom lane