Subject: RE: Windows meson build

From: "Kohei Harikae (Fujitsu)" <[email-masked]>
Date: Wed, 18 Dec 2024 02:05:20 +0000

Hi,

I apologize for this late reply.

As you advised, I was able to create the ".pc" file manually and set the dependencies using pkgconf.
Thank you.

However, I have read the PostgreSQL Documentation and did not realize that pkgconf is required.

17.4.3.2. PostgreSQL Features
-Dgssapi
  On many systems, the GSSAPI system (a part of the MIT Kerberos installation) is not installed in a location that is searched by default (e.g., /usr/include, /usr/lib). 
  In those cases, PostgreSQL will query pkg-config to detect the required compiler and linker options. 
-Dlibxml
  To use a libxml2 installation that is in an unusual location, you can set pkg-config-related environment variables (see its documentation).

Only a few options have a pkg-config description.
It would be easier to understand pkg-config in the "17.4.3. meson setup Options" section.
Below is my proposal for the document description.
How do you think about this?

17.4.3. meson setup Options
PostgreSQL will query pkg-config to detect the required compiler and linker options.
To use module installed in an unusual location for each feature (e.g. -Dgssapi, -Dlibxml), set pkg-config-related environment variables (see its documentation).

Regards,
Kohei Harikae

-----Original Message-----
From: Andres Freund <[email-masked]> 
Sent: Thursday, November 7, 2024 4:05 AM
To: Harikae, Kohei/張替 浩平 <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Subject: Re: Windows meson build

Hi,

On 2024-11-05 06:32:51 +0000, Kohei Harikae (Fujitsu) wrote:
> I do not use pkgconf in my Windows environment.
> In my Windows environment, I could not build the following OSS with meson.
> - 0001 icu
> - 0002 libxml
> - 0003 libxslt
> - 0004 lz4
> - 0005 tcl
> - 0006 zlib
> - 0007 zstd
> 
> [1]thread, I created a patch like the one in the attached file, and now I can build.
> Would you like to be able to build OSS with Windows meson without using pkgconf?

You can use pkgconf or cmake for the dependencies.  I don't want to add "raw"
dependency handling for every dependency, they each build in too many variants for that to be a sensible investment of time.

Greetings,

Andres Freund

---

From: Vladlen Popolitov <[email-masked]>
Date: Wed, 25 Dec 2024 13:28:18 +0300

Kohei Harikae (Fujitsu) писал(а) 2024-12-18 05:05:
Hi!
>   On many systems, the GSSAPI system (a part of the MIT Kerberos 
> installation) is not installed in a location that is searched by 
> default (e.g., /usr/include, /usr/lib).
>   To use a libxml2 installation that is in an unusual location, you can 
> set pkg-config-related environment variables (see its documentation).
> 
> To use module installed in an unusual location for each feature (e.g. 
> -Dgssapi, -Dlibxml), set pkg-config-related environment variables (see 
> its documentation).

Meson has more straighforward solution. It uses environment variable 
PKG_CONFIG_PATH, that can store the list of directories with all .pc 
files. Meson uses this list and in this specific order to build project. 
As wrote in meson documentation (in the source of open source project):
# Instead of relying on pkg-config or pkgconf to provide -L flags in a
# specific order, we reorder library paths ourselves, according to th
# order specified in PKG_CONFIG_PATH. See:
# https://github.com/mesonbuild/meson/issues/4271
#
It would be more clear information in PostgreSQL documentation, that all 
directories with pc files are listed in one variable.

By the way, if you need to add , f.e. libxml library to postgreSQL 
build, you can
1) build and install it using , f.e. vcpkg:
  vcpkg install libxml2:windows-x64 --x-install-root=c:\pbuild\libxml2
2) add path to pc directory to PKG_CONFIG_PATH
  SET 
PKG_CONFIG_PATH=c:\pbuild\libxml2\winsows-x64\lib\pkgconfig;%PKG_CONFIG_PATH%
3) make steps with build
  meson setup c:\builddir\... --prefix=c:\postgresdir\...

It is just one install and one manipulation with environment variable. 
No indeterminate behaviour with other variables used by specific 
packages and a libraries order.

> dependency handling for every dependency, they each build in too many 
> variants for that to be a sensible investment of time.
> 
> 
> Greetings,
> 
> Andres Freund

-- 
Best regards,

Vladlen Popolitov.

---

From: "Kohei Harikae (Fujitsu)" <[email-masked]>
Date: Fri, 27 Dec 2024 01:31:33 +0000

Hi,

Thank you for your advice.
I added a sample setting PKG_CONFIG_PATH based on your advice.

Regards,
Kohei Harikae

-----Original Message-----
From: Vladlen Popolitov <[email-masked]> 
Sent: Wednesday, December 25, 2024 7:28 PM
To: Harikae, Kohei/張替 浩平 <[email-masked]>
Cc: 'Andres Freund' <[email-masked]>; [email-masked]' <[email-masked]>
Subject: Re: Windows meson build

>   To use a libxml2 installation that is in an unusual location, you 
> can set pkg-config-related environment variables (see its documentation).
> 

Meson has more straighforward solution. It uses environment variable PKG_CONFIG_PATH, that can store the list of directories with all .pc files. Meson uses this list and in this specific order to build project. 
As wrote in meson documentation (in the source of open source project):
# Instead of relying on pkg-config or pkgconf to provide -L flags in a # specific order, we reorder library paths ourselves, according to th # order specified in PKG_CONFIG_PATH. See:
# https://github.com/mesonbuild/meson/issues/4271
#
It would be more clear information in PostgreSQL documentation, that all directories with pc files are listed in one variable.

By the way, if you need to add , f.e. libxml library to postgreSQL build, you can

It is just one install and one manipulation with environment variable. 
No indeterminate behaviour with other variables used by specific packages and a libraries order.

--
Best regards,

Vladlen Popolitov.

---

From: Vladlen Popolitov <[email-masked]>
Date: Fri, 27 Dec 2024 09:57:12 +0300

> How do you think about this?

Hi,
 From my point of view it looks good. Actual information is added,
excessive information is removed.
I think in the phrase:
"add the directory where the .pc file resides to PKG_CONFIG_PATH."
better to add wording, that PKG_CONFIG_PATH is the list of directories 
separated
by PATH separator ( ; in Windows, : in POSIX). Otherwise the reader has 
to
search additional information about this variable in meson 
documentation.

-- 
Best regards,

Vladlen Popolitov.

---

From: Vladlen Popolitov <[email-masked]>
Date: Fri, 27 Dec 2024 12:08:12 +0300

> search additional information about this variable in meson 

Hi

I think, it is better to add the other options how to configure external
libraries, if they do not have .pc file:
add meson options defined by PostgreSQL for its configuration (gettext 
library example)
  
-Dextra_include_dirs=c:\postgres\gettext\x64-windows\include,c:\otherlibs\include
  -Dextra_lib_dirs=c:\postgres\gettext\x64-windows\lib,c:\otherlibs\lib

extra_include_dirs and extra_lib_dirs are options defined by PostgreSQL. 
This options are
comma separated lists of directories, if every value does not contain 
comma itself.

-- 
Best regards,

Vladlen Popolitov.