public inbox for [email protected]  
help / color / mirror / Atom feed
From: David Steele <[email protected]>
To: Amit Langote <[email protected]>
Cc: Tom Lane <[email protected]>
Cc: Julien Rouhaud <[email protected]>
Cc: Pg Hackers <[email protected]>
Subject: Re: Views no longer in rangeTabls?
Date: Tue, 13 Jun 2023 10:57:36 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <CA+HiwqHAZVm+qDmNLvS6CT2OiNoiRhr-00B3XEkVNOi26+Rpug@mail.gmail.com>
References: <[email protected]>
	<CA+HiwqFC0xDCCiXbUjb-xisxo9PPuA8_ykn8Fz+6RbBJBE8mVA@mail.gmail.com>
	<[email protected]>
	<[email protected]>
	<[email protected]>
	<CA+HiwqFaMfM-082vwNYSAWU13T9nd62DObeNLbSTisSh6odOog@mail.gmail.com>
	<[email protected]>
	<[email protected]>
	<20230610131857.cqrsm6pwq3k47yuv@jrouhaud>
	<[email protected]>
	<CA+HiwqF1CgsZKvBW_Gz9tErKfOp4t=PQgUKvrvWBG0HP8LdAXQ@mail.gmail.com>
	<[email protected]>
	<CA+HiwqHAZVm+qDmNLvS6CT2OiNoiRhr-00B3XEkVNOi26+Rpug@mail.gmail.com>

On 6/13/23 10:27, Amit Langote wrote:
> On Tue, Jun 13, 2023 at 4:44 PM David Steele <[email protected]> wrote:
> 
>> I decided to go with the following because I think it
>> is easier to read:
>>
>> /* We only care about tables/views and can ignore subqueries, etc. */
>> if (!(rte->rtekind == RTE_RELATION ||
>>         (rte->rtekind == RTE_SUBQUERY && rte->relkind == RELKIND_VIEW)))
>>       continue;
> 
> It didn't occur to me so far to mention it but this could be replaced with:
> 
>      if (rte->perminfoindex != 0)
> 
> and turn that condition into an Assert instead, like the loop over
> range table in ExecCheckPermissions() does.

Hmmm, that might work, and save us a filter on rte->perminfoindex later 
on (to filter out table partitions). Thanks for the tip!

>>> I considered adding Assert(relkind == RELKIND_VIEW) in all places that
>>> have the "rte->rtekind == RTE_SUBQUERY && OidIsValid(rte->relid)"
>>> condition, but that seemed like an overkill, so only added one in the
>>> #ifdef USE_ASSERT_CHECKING block in ExecCheckPermissions() that
>>> f75cec4fff877 added.
>>
>> This seems like a good place for the assert.
> 
> I added a comment above this Assert.
> 
> I'd like to push this tomorrow barring objections.

+1 for the new comment.

Regards,
-David






view thread (11+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected]
  Subject: Re: Views no longer in rangeTabls?
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox