Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1s0SXZ-004NJD-Qk for pgsql-hackers@arkaria.postgresql.org; Fri, 26 Apr 2024 20:51:29 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1s0SXW-00FnuO-Rh for pgsql-hackers@arkaria.postgresql.org; Fri, 26 Apr 2024 20:51:27 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1s0SXW-00FnqA-Hy for pgsql-hackers@lists.postgresql.org; Fri, 26 Apr 2024 20:51:27 +0000 Received: from sss.pgh.pa.us ([68.162.161.243]) by makus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1s0SXU-000CUd-N1 for pgsql-hackers@postgresql.org; Fri, 26 Apr 2024 20:51:26 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 43QKpHdG030208; Fri, 26 Apr 2024 16:51:17 -0400 From: Tom Lane To: Robert Haas cc: Michael Paquier , "Anton A. Melnikov" , Daniel Gustafsson , Peter Eisentraut , PostgreSQL Hackers Subject: Re: Use XLOG_CONTROL_FILE macro everywhere? In-reply-to: References: <0841ec77-47e5-452a-adb4-c6fa55d605fc@postgrespro.ru> <474746ef-fa9f-400e-902e-3bb018320ca0@eisentraut.org> <44faf5a1-1e84-4ae5-9ea7-106af77cf96b@postgrespro.ru> <6457915f-f880-452d-a4ae-21a5bfbccbd3@postgrespro.ru> Comments: In-reply-to Robert Haas message dated "Fri, 26 Apr 2024 09:06:59 -0400" MIME-Version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-ID: <30206.1714164677.1@sss.pgh.pa.us> Content-Transfer-Encoding: quoted-printable Date: Fri, 26 Apr 2024 16:51:17 -0400 Message-ID: <30207.1714164677@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Robert Haas writes: > On Wed, Apr 24, 2024 at 8:04=E2=80=AFPM Michael Paquier wrote: >> Not sure that I would bother with a second one. But, well, why not if >> people want to rename it, as long as you keep compatibility. > I vote for just standardizing on XLOG_CONTROL_FILE. That name seems > sufficiently intuitive to me, and I'd rather have one identifier for > this than two. It's simpler that way. +1. Back when we did the great xlog-to-wal renaming, we explicitly agreed that we wouldn't change internal symbols referring to xlog. It might or might not be appropriate to revisit that decision, but I sure don't want to do it piecemeal, one symbol at a time. Also, if we did rename this one, the logical choice would be WAL_CONTROL_FILE not PG_CONTROL_FILE. regards, tom lane