Subject: Re: Windows vs recovery tests

From: Tom Lane <[email-masked]>
Date: Wed, 12 Jan 2022 16:15:12 -0500

Andrew Dunstan <[email-masked]> writes:
> For some considerable time the recovery tests have been at best flaky on
> Windows, and at worst disastrous (i.e. they can hang rather than just
> fail).

How long is "some considerable time"?  I'm wondering if this isn't
the same issue under discussion in

https://www.postgresql.org/message-id/flat/CA%2BhUKG%2BOeoETZQ%3DQw5Ub5h3tmwQhBmDA%3DnuNO3KG%3DzWfUypFAw%40mail.gmail.com

			regards, tom lane

---

From: Michail Nikolaev <[email-masked]>
Date: Thu, 13 Jan 2022 00:37:44 +0300

Hello.

It is also could be related -
https://www.postgresql.org/message-id/flat/20220112112425.pgzymqcgdy62e7m3%40jrouhaud#097b54a539ac3091ca4e4ed8ce9ab89c
(both Windows and Linux cases.

Best regards,
Michail.

---

From: Andrew Dunstan <[email-masked]>
Date: Wed, 12 Jan 2022 17:22:37 -0500

> https://www.postgresql.org/message-id/flat/CA%2BhUKG%2BOeoETZQ%3DQw5Ub5h3tmwQhBmDA%3DnuNO3KG%3DzWfUypFAw%40mail.gmail.com

many months - this isn't a new thing.

I'm going to set up a system where I run the test in a fairly tight loop
and see if I can find out more.

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com