Received: from maia.hub.org (unknown [200.46.204.183]) by mail.postgresql.org (Postfix) with ESMTP id B3CF3632772 for ; Sat, 10 Oct 2009 04:46:04 -0300 (ADT) Received: from mail.postgresql.org ([200.46.204.86]) by maia.hub.org (mx1.hub.org [200.46.204.183]) (amavisd-maia, port 10024) with ESMTP id 34907-08 for ; Sat, 10 Oct 2009 07:45:54 +0000 (UTC) X-Greylist: from auto-whitelisted by SQLgrey-1.7.6 Received: from mail-ew0-f218.google.com (mail-ew0-f218.google.com [209.85.219.218]) by mail.postgresql.org (Postfix) with ESMTP id D0DAE632357 for ; Sat, 10 Oct 2009 04:45:53 -0300 (ADT) Received: by ewy18 with SMTP id 18so1928478ewy.19 for ; Sat, 10 Oct 2009 00:45:51 -0700 (PDT) MIME-Version: 1.0 Received: by 10.216.87.83 with SMTP id x61mr1158492wee.7.1255160751331; Sat, 10 Oct 2009 00:45:51 -0700 (PDT) In-Reply-To: <603c8f070909270954n585e8e8am9eb1c187dec9fe19@mail.gmail.com> References: <4A37BF63.50008@pjmodos.net> <4A6059B4.5010004@pjmodos.net> <4A607997.3030305@pjmodos.net> <21542.1249492707@sss.pgh.pa.us> <4A7F56A0.5060705@pjmodos.net> <4A7F5853.5010506@pjmodos.net> <20090920145011.GA24273@toroid.org> <4AB75A51.5060807@pjmodos.net> <603c8f070909270954n585e8e8am9eb1c187dec9fe19@mail.gmail.com> From: Jaime Casanova Date: Sat, 10 Oct 2009 02:45:35 -0500 Message-ID: <3073cc9b0910100045qdcb2b3duabc05eb727ea0091@mail.gmail.com> Subject: Re: GRANT ON ALL IN schema To: Robert Haas Cc: Petr Jelinek , Abhijit Menon-Sen , pgsql-hackers@postgresql.org Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: quoted-printable X-Virus-Scanned: Maia Mailguard 1.0.1 X-Spam-Status: No, hits=-0.74 tagged_above=-10 required=5 tests=BAYES_20=-0.74 X-Spam-Level: X-Archive-Number: 200910/646 X-Sequence-Number: 147458 On Sun, Sep 27, 2009 at 11:54 AM, Robert Haas wrote= : > > If this patch looks good now, can you mark it Ready for Committer in > the CommitFest app? =C2=A0If there are any remaining issues, please post = a > further review. > while i'm not the reviewer this patch doesn't apply cleanly anymore... some comments: 1) in docs for REVOKE you're omitting the SCHEMA part of the new syntax. 2) i think that getNamespacesObjectsOids() could be rewritten in something = like: + { + List *objects =3D NIL; + ListCell *cell; + char *nspname; + Oid namespaceId; + + foreach(cell, nspnames) + { + List *relations =3D NIL; + + nspname =3D strVal(lfirst(cell)); + namespaceId =3D LookupExplicitNamespace(nspname); + switch (objtype) + { + /* do what you need for every type of object here */ + + } i think this is more readable --=20 Atentamente, Jaime Casanova Soporte y capacitaci=C3=B3n de PostgreSQL Asesor=C3=ADa y desarrollo de sistemas Guayaquil - Ecuador Cel. +59387171157