Subject: tzdata 2025a and timestamptz.out

From: Christoph Berg <[email-masked]>
Date: Mon, 20 Jan 2025 20:23:10 +0100

It happened again:

News for the tz database

Release 2025a - 2025-01-15 10:47:24 -0800

  Briefly:
    ...
    Improve pre-1991 data for the Philippines.

 SELECT make_timestamptz(1846, 12, 10, 0, 0, 0, 'Asia/Manila') AT TIME ZONE 'UTC';
          timezone
 --------------------------
- Wed Dec 09 15:56:00 1846
+ Wed Dec 09 15:56:08 1846

Christoph

---

From: Tom Lane <[email-masked]>
Date: Mon, 20 Jan 2025 15:09:00 -0500

>  SELECT make_timestamptz(1846, 12, 10, 0, 0, 0, 'Asia/Manila') AT TIME ZONE 'UTC';

Grumble.  Let's switch to using Asia/Singapore in this test case.
It has a roughly similar UTC offset, and that offset hasn't
changed in tzdb since 2003.  (Gotta love "git blame".)

			regards, tom lane