Subject: pgsql: Cleanup comments/docs around the new shmem request callbacks

From: Heikki Linnakangas <[email-masked]>
Date: Tue, 07 Jul 2026 19:40:07 +0000

Cleanup comments/docs around the new shmem request callbacks

Make it explicit in the docs that the shmem initialization callbacks
are called while holding ShmemIndexLock.

Reviewed-by: Ashutosh Bapat <[email-masked]>
Discussion: https://www.postgresql.org/message-id/CAExHW5sHs+eSiTDOd14buayc6JbBX=[email-masked]
Backpatch-through: 19

Branch
------
REL_19_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/a53d6d8aea8fe703d86dd2bdc0a3d86800eca7c3

Modified Files
--------------
doc/src/sgml/xfunc.sgml         | 4 ++--
src/backend/storage/ipc/shmem.c | 7 +++++--
2 files changed, 7 insertions(+), 4 deletions(-)

---

From: Erik Rijkers <[email-masked]>
Date: Wed, 8 Jul 2026 04:26:10 +0200

> https://git.postgresql.org/pg/commitdiff/a53d6d8aea8fe703d86dd2bdc0a3d86800eca7c3

Hi,

in doc/src/sgml/xfunc.sgml

the sentence:
   "two backends trying to initializing the memory area"

should be:
   "two backends trying to initialize the memory area"

Thanks,

Erik

---

From: Heikki Linnakangas <[email-masked]>
Date: Wed, 8 Jul 2026 10:25:27 +0300

>    "two backends trying to initialize the memory area"

Fixed, thanks!

- Heikki