Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1ogtoQ-0003A4-1f for pgsql-hackers@arkaria.postgresql.org; Fri, 07 Oct 2022 20:19:14 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1ogtoN-0007B2-PM for pgsql-hackers@arkaria.postgresql.org; Fri, 07 Oct 2022 20:19:11 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1ogtoN-00075y-Fr for pgsql-hackers@lists.postgresql.org; Fri, 07 Oct 2022 20:19:11 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1ogtoI-0002rI-CE for pgsql-hackers@postgresql.org; Fri, 07 Oct 2022 20:19:08 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 297KIxCX3347533; Fri, 7 Oct 2022 16:18:59 -0400 From: Tom Lane To: Nathan Bossart cc: Michael Paquier , Joe Conway , Joshua Brindle , PostgreSQL-development Subject: Re: use has_privs_of_role() for pg_hba.conf In-reply-to: <20221007194430.GA550749@nathanxps13> References: <20220401220648.GA615994@nathanxps13> <20220404142551.GB663209@nathanxps13> <491dba16-55df-d5fd-1ae7-01b5140987f0@joeconway.com> <20221006174343.GA444656@nathanxps13> <20221007032711.GA499771@nathanxps13> <20221007194430.GA550749@nathanxps13> Comments: In-reply-to Nathan Bossart message dated "Fri, 07 Oct 2022 12:44:30 -0700" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <3347531.1665173939.1@sss.pgh.pa.us> Date: Fri, 07 Oct 2022 16:18:59 -0400 Message-ID: <3347532.1665173939@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Nathan Bossart writes: > On Fri, Oct 07, 2022 at 03:34:51PM +0900, Michael Paquier wrote: >> Thanks. I would perhaps use names less generic than role{1,2,3} for >> the roles or "role1" for the database name, but the logic looks >> sound. > Here is a new version with more descriptive role names. There's another problem there, which is that buildfarm animals using -DENFORCE_REGRESSION_TEST_NAME_RESTRICTIONS will complain about role names that don't start with "regress_". regards, tom lane