Subject: Re: [PATCH] Fix a tiny typo in the documentation

From: "David G. Johnston" <[email-masked]>
Date: Wed, 22 Jan 2025 06:38:34 -0700

On Wednesday, January 22, 2025, Daniel Gustafsson <[email-masked]> wrote:

> > On 22 Jan 2025, at 11:23, Daniel Gustafsson <[email-masked]> wrote:
> >> On 22 Jan 2025, at 09:27, Robin Dupret <[email-masked]> wrote:
>
> >> -    special provision: you must write
> >> +    special provision you must write:
> >
> > Nice catch, will fix.
>
> Re-reading it I think both placements of ':' are grammatically correct (not
> being a native speaker might trick me).  The current one is, I'm sure,
> intentional but I agree it looks a bit odd to continue the sentence into a
> <programlisting> block and ending it without punctuation.  For now I'm
> inclined
> to leave it though.
>
>
The colon does belong after provision, not write.  If the colon is
bothersome rewrite to avoid it altogether.  But the status quo works for me.

David J.

---

From: Tom Lane <[email-masked]>
Date: Wed, 22 Jan 2025 10:34:16 -0500

>> being a native speaker might trick me).

> bothersome rewrite to avoid it altogether.  But the status quo works for me.

I agree: removing the colon from where it is is strictly worse.
There should be some kind of pause or separation there.
Conceivably we could do

-    special provision: you must write
+    special provision. You must write:

But like David, I don't feel a need to change anything here.  There
are many places in our docs where we flow into a <programlisting> or
similar block without punctuation, and most of them read just fine
to me.

			regards, tom lane

---

From: Robin Dupret <[email-masked]>
Date: Thu, 23 Jan 2025 15:42:06 +0100

> similar block without punctuation, and most of them read just fine
Yes, you're right. On the other hand, it is very common to see a colon
right before a block with code or error message so maybe changing it
for a semi-colon or period would make reading less "odd".

But anyway, I'm fine if you leave it as is. :-)
Thanks for your time.