Subject: Re: gcc 13 warnings

From: Pavel Stehule <[email-masked]>
Date: Thu, 16 Mar 2023 17:00:47 +0100

čt 16. 3. 2023 v 16:43 odesílatel Tom Lane <[email-masked]> napsal:

> Melanie Plageman <[email-masked]> writes:
> > On Thu, Mar 16, 2023 at 9:40 AM Pavel Stehule <[email-masked]>
> wrote:
> >> ../src/include/varatt.h:230:36: warning: array subscript 0 is outside
> array bounds of ‘char[0]’ [-Warray-bounds=]
>
> > I see these with gcc 12.2.0 also.
>
> Hmm, I do not see any warnings on HEAD with Fedora 37's gcc 12.2.1.
> What non-default configure switches, CFLAGS, etc are you using?
>

meson build without any settings

I think so it is related to meson build, I didn't see these warnings with
autoconf

regards

Pavel

>                         regards, tom lane

---

From: Tom Lane <[email-masked]>
Date: Thu, 16 Mar 2023 12:10:27 -0400

> I think so it is related to meson build, I didn't see these warnings with

It wouldn't be entirely surprising if meson is selecting some -W
switches that the configure script doesn't ... but I don't know
where to check or change that.

If that is the case, do we want to beat meson over the head till
it stops doing that, or try to silence the warnings?  The ones
you show here don't look terribly helpful ...

			regards, tom lane