Subject: Re: Selectively invalidate caches in pgoutput module

From: Zharkov Roman <[email-masked]>
Date: Fri, 16 Jan 2026 21:18:48 +0700

Hello,

It seems I found the not corresponding comment "CallSyscacheCallbacks" 
on the function "CallRelSyncCallbacks(Oid relid)"  [1].
This is from commit #3abe9dc [2].

On Monday, March 03, 2025 14:57 +07, "Hayato Kuroda (Fujitsu)" 
<[email-masked]> wrote:

> Hi, this is a fork thread from [1]. I want to propose a small 
> optimization for
> logical replication system.

[1] 
https://github.com/postgres/postgres/blob/master/src/backend/utils/cache/inval.c#L1917C4-L1917C25
[2] 
https://github.com/postgres/postgres/commit/3abe9dc18892b9f69bb48a2eb21fbe5cf348a489#diff-a2d058b87a058c0877ab30776da08a5b884944ece132cbbdf916ec06c29611fdR1903

--
Roman Zharkov

---

From: "Hayato Kuroda (Fujitsu)" <[email-masked]>
Date: Thu, 19 Feb 2026 13:06:34 +0000

Dear Zharkov,

Sorry for the very late reply, I completely missed.

After considering bit more, we may be able to remove CallRelSyncCallbacks() function
in the first place. There is only a caller for now and I cannot come up with the case
where we want to call callbacks without the invalidations from other sides.

Best regards,
Hayato Kuroda
FUJITSU LIMITED