Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1ta0MQ-00F9RL-1o for pgsql-hackers@arkaria.postgresql.org; Mon, 20 Jan 2025 22:35:10 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1ta0MO-007XbP-NR for pgsql-hackers@arkaria.postgresql.org; Mon, 20 Jan 2025 22:35:08 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1ta0MN-007XZx-NC for pgsql-hackers@lists.postgresql.org; Mon, 20 Jan 2025 22:35:08 +0000 Received: from fout-a3-smtp.messagingengine.com ([103.168.172.146]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1ta0MJ-000byz-0f for pgsql-hackers@lists.postgresql.org; Mon, 20 Jan 2025 22:35:07 +0000 Received: from phl-compute-01.internal (phl-compute-01.phl.internal [10.202.2.41]) by mailfout.phl.internal (Postfix) with ESMTP id 0AD4A1380847; Mon, 20 Jan 2025 17:35:01 -0500 (EST) Received: from phl-imap-09 ([10.202.2.99]) by phl-compute-01.internal (MEProxy); Mon, 20 Jan 2025 17:35:01 -0500 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=eulerto.com; h= cc:cc:content-type:content-type:date:date:from:from:in-reply-to :in-reply-to:message-id:mime-version:references:reply-to:subject :subject:to:to; s=fm3; t=1737412501; x=1737498901; bh=AyFpnYNSh1 Z9S/sjBa3RXnf1jtOz04aYXhKx7q07144=; b=b3xtlOTfD9FLU5K+DjeNB4WUJ/ dS9MuowkF+H0FRSsBDCRKaDZ3KM91IrBmy9fdxVce9bh7ZrB47I8Laz6v3sW4MRO VnLfcz/PtMS2+ETWirOS/F9G2HHNpgvvao3Bq4P12Yx5YbuQ3H2hm0GsaJ878o4u 5KUGlWCkomgNonp8OkpUaolYxkXGIgaVUB3eKJEb2e4UR9QPex2a6FU8GCVvJ9jE FHq8zBibKLb4n1gqhzCR3JLwGsEw7TRHnNSvIzQbUvI7hOjI8rI2yktEpdABDBor ztuqZ69wAyDpzsb6s7NgctzGSbCxaJfHcnQmsWEcthO/fbTpJyIPMtmKbfdQ== DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d= messagingengine.com; h=cc:cc:content-type:content-type:date:date :feedback-id:feedback-id:from:from:in-reply-to:in-reply-to :message-id:mime-version:references:reply-to:subject:subject:to :to:x-me-proxy:x-me-sender:x-me-sender:x-sasl-enc; s=fm2; t= 1737412501; x=1737498901; bh=AyFpnYNSh1Z9S/sjBa3RXnf1jtOz04aYXhK x7q07144=; b=aVG6YnJ/BE2P14Lu+mj2owOG86nrexaoXfmoNUwsQqC7hTpEBHH OePmUFCL43y/tWSGKAMrn6rHbqbxdS1g0XjzzLJQ0JAvQkSIAJ6t4P6L34B7mfcS DfNY42LG7T86M0pyPqW4q50YbICJps9c0+TdWTLVFiSLX+3DyHU91SX7ECr0dzrM +6Jpsd8xY3Dvdm0pjgMS1NUzulRz+7sc1Bj+0tfVGY5cwaPQfW2CXoOhE4JYWNTS PAcqfbi+qwSeDFwqoUKoMbZ2VIQbhLQx3PNA1nxA1XW/qAK6kMindmzY2pun/8G4 Q9QH1bZqlqUzsVfTMJjS/6N2aXIuQStNqvw== X-ME-Sender: X-ME-Proxy-Cause: gggruggvucftvghtrhhoucdtuddrgeefuddrudejtdcutefuodetggdotefrodftvfcurf hrohhfihhlvgemucfhrghsthforghilhdpggftfghnshhusghstghrihgsvgdpuffrtefo kffrpgfnqfghnecuuegrihhlohhuthemuceftddtnecusecvtfgvtghiphhivghnthhsuc dlqddutddtmdenucfjughrpefoggffhffvvefkjghfufgtsegrtderreertdejnecuhfhr ohhmpedfgfhulhgvrhcuvfgrvhgvihhrrgdfuceovghulhgvrhesvghulhgvrhhtohdrtg homheqnecuggftrfgrthhtvghrnhepudelkeetieeujeejhffghfeiudfhteegjeektdej vdetkeegtdejudehueehfeeknecuffhomhgrihhnpegvnhhtvghrphhrihhsvggusgdrtg homhenucevlhhushhtvghrufhiiigvpedtnecurfgrrhgrmhepmhgrihhlfhhrohhmpegv uhhlvghrsegvuhhlvghrthhordgtohhmpdhnsggprhgtphhtthhopeejpdhmohguvgepsh hmthhpohhuthdprhgtphhtthhopehpvghtvghrsegvihhsvghnthhrrghuthdrohhrghdp rhgtphhtthhopegvuhhlvghrrdhtrghvvghirhgrsegvnhhtvghrphhrihhsvggusgdrtg homhdprhgtphhtthhopehsmhhithhhphgsvddvhedtsehgmhgrihhlrdgtohhmpdhrtghp thhtohepihhlmhgrrhhisehilhhmrghrihdrohhrghdprhgtphhtthhopehpghhsqhhlqd hhrggtkhgvrhhssehlihhsthhsrdhpohhsthhgrhgvshhqlhdrohhrghdprhgtphhtthho pehmihgthhgrvghlsehprghquhhivghrrdighiiipdhrtghpthhtohepthhglhesshhssh drphhghhdrphgrrdhush X-ME-Proxy: Feedback-ID: i0c21471d:Fastmail Received: by mailuser.phl.internal (Postfix, from userid 501) id 2981F780069; Mon, 20 Jan 2025 17:35:00 -0500 (EST) X-Mailer: MessagingEngine.com Webmail Interface MIME-Version: 1.0 Date: Mon, 20 Jan 2025 19:33:28 -0300 From: "Euler Taveira" To: =?UTF-8?Q?Dagfinn_Ilmari_Manns=C3=A5ker?= , "Peter Smith" Cc: "Michael Paquier" , "Tom Lane" , "PostgreSQL Hackers" , "Peter Eisentraut" , "Euler Taveira" Message-Id: <3b6b2595-9822-4e4f-91ee-b6a44dc4b542@app.fastmail.com> In-Reply-To: <87o70143p6.fsf@wibble.ilmari.org> References: <556792.1733967676@sss.pgh.pa.us> <564915.1733971586@sss.pgh.pa.us> <87pllx5cqn.fsf@wibble.ilmari.org> <87msh159c3.fsf@wibble.ilmari.org> <87o70143p6.fsf@wibble.ilmari.org> Subject: Re: pg_createsubscriber TAP test wrapping makes command options hard to read. Content-Type: multipart/alternative; boundary=7c99076c703b4840807e5e1c61f8cc77 List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk --7c99076c703b4840807e5e1c61f8cc77 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: quoted-printable On Mon, Jan 20, 2025, at 5:42 PM, Dagfinn Ilmari Manns=C3=A5ker wrote: > Peter Smith writes: >=20 > > > > In your v4 patch, there is a fragment (below) that replaces a double > > '--verbose' switch with just a single '--verbose'. > > > > As I have only recently learned, the '--verbose'' switch has a > > cumulative effect [1], so the original double '--verbose' was probab= ly > > deliberate so it should be kept that way. >=20 > I was going to say that if it were deliberate, I would have expected t= he > two `--verbose` swithces to be together, but then I noticed that the > --recovery-timeout switch was added later (commit 04c8634c0c4d), rather > haphazardly between them. Still, I would have expected a comment as to > why this command was being invoked extra-verbosely, but I'll restore it > in the next version. I ran pgperltidy before the final version and one of the things I didn't understand at the time is why it is not stable. I just kept similar patt= ern from other test files. Good to know that the fat comma has a nice format= ting. It is kind of annoying to keep version 20230309 around to run perltidy. = Do we have any other alternatives? (I know that perltidier is a hack to work a= round some perltidy ugliness. Unfortunately, these pre/post filters are a sign= that perltidy does not intend to add such feature.) The double --verbose is intentional to (i) show extra information and (i= i) make sure it won't break. The commit 04c8634c0c4 that added the recovery time= out option separated the doubled verbose option; it was not intentional. We = can certainly keep them together. I checked your patch with perltidy 20220613-1 and it looks good to me. -- Euler Taveira EDB https://www.enterprisedb.com/ --7c99076c703b4840807e5e1c61f8cc77 Content-Type: text/html; charset=utf-8 Content-Transfer-Encoding: quoted-printable
On Mon, Jan 20,= 2025, at 5:42 PM, Dagfinn Ilmari Manns=C3=A5ker wrote:
Peter Smith <smithpb2250@gmail.com> writes:
<= /div>

>
> In your v4 patch, there= is a fragment (below) that replaces a  double
> '= --verbose' switch with just a single '--verbose'.
>
=
> As I have only recently learned, the '--verbose'' switch= has a
> cumulative effect [1], so the original double = '--verbose' was probably
> deliberate so it should be k= ept that way.

I was going to say that if it= were deliberate, I would have expected the
two `--verbose= ` swithces to be together, but then I noticed that the
--r= ecovery-timeout switch was added later (commit 04c8634c0c4d), rather
=
haphazardly between them.  Still, I would have expected = a comment as to
why this command was being invoked extra-v= erbosely, but I'll restore it
in the next version.

I ran pgperltidy before the final ver= sion and one of the things I didn't
understand at the time= is why it is not stable. I just kept similar pattern
from other test files. Good to know th= at the fat comma has a nice formatting.
It is kind of annoying to keep version 20230309 arou= nd to run perltidy. Do we
have any other alternatives? (I know that perltidier is a hack to = work around
some per= ltidy ugliness. Unfortunately, these pre/post filters are a sign that
perltidy does not inte= nd to add such feature.)
=

The double --v= erbose is intentional to (i) show extra information and (ii) make
sure it won't break. The c= ommit 04c8634c0c4 that added the recovery timeout
option separated the doubled verbose optio= n; it was not intentional. We can
certainly keep them together.

I checked your patch with perltid= y 20220613-1 and it looks good to me.


<= /div>
--
Euler Taveira

--7c99076c703b4840807e5e1c61f8cc77--