Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jZy5i-00029E-9r for pgsql-hackers@arkaria.postgresql.org; Sat, 16 May 2020 14:47:06 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1jZy5f-0002E7-QS for pgsql-hackers@arkaria.postgresql.org; Sat, 16 May 2020 14:47:03 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jZy5f-0002E0-JU for pgsql-hackers@lists.postgresql.org; Sat, 16 May 2020 14:47:03 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jZy5c-0001d8-UY for pgsql-hackers@lists.postgresql.org; Sat, 16 May 2020 14:47:03 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id 04GEkvvj004506; Sat, 16 May 2020 10:46:57 -0400 From: Tom Lane To: Thomas Munro cc: PostgreSQL Hackers Subject: Re: Our naming of wait events is a disaster. In-reply-to: <4929.1589337345@sss.pgh.pa.us> References: <21247.1589296570@sss.pgh.pa.us> <4929.1589337345@sss.pgh.pa.us> Comments: In-reply-to Tom Lane message dated "Tue, 12 May 2020 22:35:45 -0400" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <4504.1589640417.1@sss.pgh.pa.us> Date: Sat, 16 May 2020 10:46:57 -0400 Message-ID: <4505.1589640417@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk I wrote: > Thomas Munro writes: >> On Wed, May 13, 2020 at 3:16 AM Tom Lane wrote: >>> Hash/Batch/Allocating >>> Hash/Batch/Electing >>> Hash/Batch/Loading >>> Hash/GrowBatches/Allocating >> Perhaps we should also drop the 'ing' from the verbs, to be more like >> ...Read etc. > Yeah, that aspect was bothering me too. Comparing these to other > wait event names, you could make a case for either "Allocate" or > "Allocation"; but there are no other names with -ing. After contemplating these for a bit, my proposal is to drop the slashes and convert "verbing" to "verb", giving HashBatchAllocate HashBatchElect HashBatchLoad HashBuildAllocate HashBuildElect HashBuildHashInner HashBuildHashOuter HashGrowBatchesAllocate HashGrowBatchesDecide HashGrowBatchesElect HashGrowBatchesFinish HashGrowBatchesRepartition HashGrowBucketsAllocate HashGrowBucketsElect HashGrowBucketsReinsert In addition to that, I think the ClogGroupUpdate event needs to be renamed to XactGroupUpdate, since we changed "clog" to "xact" in the exposed SLRU and LWLock names. (There are some other names that I wouldn't have picked in a green field, but it's probably not worth the churn to change them.) Also, as previously noted, ProcSignalBarrier should be in the IPC event class not IO. Barring objections, I'll make these things happen before beta1. regards, tom lane