Subject: Re: speedup ALTER TABLE ADD CHECK CONSTRAINT.

From: Sergei Kornilov <[email-masked]>
Date: Sun, 01 Dec 2024 19:06:48 +0300

Hello!
Thanks for the patch, but I think using SPI is still not allowed here: https://www.postgresql.org/message-id/9878.1511970441%40sss.pgh.pa.us

> if it uses SPI for sub-operations of ALTER TABLE I think that is sufficient reason to reject it out of hand.

regards, Sergei

---

From: jian he <[email-masked]>
Date: Tue, 3 Dec 2024 14:43:00 +0800

> > if it uses SPI for sub-operations of ALTER TABLE I think that is sufficient reason to reject it out of hand.

Thanks for dropping this link.
i wonder what was your thoughts about this
(https://www.postgresql.org/message-id/900056D1-32DF-4927-8251-3E0C0DC407FD%40anarazel.de)
at that time?