Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jYhFO-0000vU-FN for pgsql-hackers@arkaria.postgresql.org; Wed, 13 May 2020 02:35:50 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1jYhFN-0002BT-59 for pgsql-hackers@arkaria.postgresql.org; Wed, 13 May 2020 02:35:49 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jYhFM-00028C-UL for pgsql-hackers@lists.postgresql.org; Wed, 13 May 2020 02:35:48 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jYhFK-0006Qo-PU for pgsql-hackers@lists.postgresql.org; Wed, 13 May 2020 02:35:47 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id 04D2Zjsd004930; Tue, 12 May 2020 22:35:45 -0400 From: Tom Lane To: Thomas Munro cc: PostgreSQL Hackers Subject: Re: Our naming of wait events is a disaster. In-reply-to: References: <21247.1589296570@sss.pgh.pa.us> Comments: In-reply-to Thomas Munro message dated "Wed, 13 May 2020 14:30:09 +1200" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <4928.1589337345.1@sss.pgh.pa.us> Date: Tue, 12 May 2020 22:35:45 -0400 Message-ID: <4929.1589337345@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Thomas Munro writes: > On Wed, May 13, 2020 at 3:16 AM Tom Lane wrote: >> Hash/Batch/Allocating >> Hash/Batch/Electing >> Hash/Batch/Loading >> Hash/GrowBatches/Allocating > Perhaps we should also drop the 'ing' from the verbs, to be more like > ...Read etc. Yeah, that aspect was bothering me too. Comparing these to other wait event names, you could make a case for either "Allocate" or "Allocation"; but there are no other names with -ing. regards, tom lane