Received: from makus.postgresql.org (makus.postgresql.org [98.129.198.125]) by mail.postgresql.org (Postfix) with ESMTP id AC77D1E3525D for ; Thu, 12 Jul 2012 22:18:24 -0300 (ADT) Received: from mail-pb0-f46.google.com ([209.85.160.46]) by makus.postgresql.org with esmtp (Exim 4.72) (envelope-from ) id 1SpUWV-0007kw-LF for pgsql-hackers@postgresql.org; Fri, 13 Jul 2012 01:18:24 +0000 Received: by pbbrp8 with SMTP id rp8so4598106pbb.19 for ; Thu, 12 Jul 2012 18:18:10 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; bh=AIiODKvx3Nf9GWKUBRrpBVvQ3u/I/XyD7GvP+MrFLPw=; b=dtRABu0Mknd6eWC6JwPFCxw+P0QClFiaI7ULrJIGZRuZ0Eji1HaQCR0wWIKqrO8Xsa neEr2abdpB2XAmdNY3TaemNCxqhckIyyF8zl2IRTZ1rbXztJKLPAFgnAp/ipmYjyg8wq m0Zv+OKwGnnRpB20F5emllmDVF5xhCB1O2peVNrs5gfVsZzKr/85bNX1l17R3EHwWTnx PJsHS4TIEl9statKq0tJPTILo8MC/agNJpc6kPkE/SJSUwHnKIJJmbYr6EGapajDWOTs lWXkEnJqN/4eAq9Qxh1rXvsulgfGw0D8ArN9tVeJhQEyux+9S0pQ8Vo94k128uUUMxKg bjxg== Received: by 10.68.233.193 with SMTP id ty1mr10022469pbc.47.1342142290686; Thu, 12 Jul 2012 18:18:10 -0700 (PDT) Received: from [192.168.1.99] ([61.199.203.168]) by mx.google.com with ESMTPS id qa5sm4888306pbb.19.2012.07.12.18.18.08 (version=SSLv3 cipher=OTHER); Thu, 12 Jul 2012 18:18:09 -0700 (PDT) Message-ID: <4FFF7750.5080208@gmail.com> Date: Fri, 13 Jul 2012 10:18:08 +0900 From: Shigeru HANADA User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120614 Thunderbird/13.0.1 MIME-Version: 1.0 To: Kohei KaiGai CC: Peter Eisentraut , PostgreSQL-development Subject: Re: pgsql_fdw in contrib References: <4FD9D947.1020803@gmail.com> <1342040659.2712.14.camel@vanquo.pezone.net> <4FFEAAA9.4080000@gmail.com> In-Reply-To: Content-Type: text/plain; charset=ISO-2022-JP Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.6 (--) X-Archive-Number: 201207/581 X-Sequence-Number: 211264 (2012/07/12 20:48), Kohei KaiGai wrote: > It seems to me what postgresql_fdw_validator() is doing looks like > a function to be named as "libpq_fdw_validator()". > > How about your opinion? It will help this namespace conflicts. I'd prefer dblink_fdw_validator. The name "libpq_fdw_validator" impresses me that a concrete FDW named "libpq_fdw" is somewhere and it retrieves external data *from* libpq. Indeed postgresql_fdw_validator allows only some of libpq options at the moment, but we won't be able to rename it for backward compatibility even if it wants to have non-libpq options in the future. IMO basically each FDW validator should be owned by a particular FDW, because in most cases validator should know FDW's internal deeply. In addition, it would want to have new options for new features. Besides naming, as mentioned upthread, removing hard-coded libpq options list from dblink and leaving it to libpq client library would make dblink more robust about libpq option changes in future. Regards, -- Shigeru HANADA