Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gKNNS-0008Ar-C3 for pgsql-hackers@arkaria.postgresql.org; Wed, 07 Nov 2018 12:56:10 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1gKNNQ-0005O5-56 for pgsql-hackers@arkaria.postgresql.org; Wed, 07 Nov 2018 12:56:08 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gKNNP-0005Mq-Tq for pgsql-hackers@lists.postgresql.org; Wed, 07 Nov 2018 12:56:07 +0000 Received: from mx1.redhat.com ([209.132.183.28]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1gKNNN-0005pf-0B for pgsql-hackers@postgresql.org; Wed, 07 Nov 2018 12:56:07 +0000 Received: from smtp.corp.redhat.com (int-mx02.intmail.prod.int.phx2.redhat.com [10.5.11.12]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by mx1.redhat.com (Postfix) with ESMTPS id AA1643002303; Wed, 7 Nov 2018 12:56:01 +0000 (UTC) Received: from nb.usersys.redhat.com (unknown [10.43.2.86]) by smtp.corp.redhat.com (Postfix) with ESMTP id A5BFB67153; Wed, 7 Nov 2018 12:56:00 +0000 (UTC) From: Pavel Raiskup To: Tom Lane Cc: Robert Haas , "pgsql-hackers@postgresql.org" , Devrim =?ISO-8859-1?Q?G=DCND=DCZ?= Subject: Re: plruby: rb_iterate symbol clash with libruby.so Date: Wed, 07 Nov 2018 13:55:57 +0100 Message-ID: <5127122.UsUPqPCgps@nb.usersys.redhat.com> In-Reply-To: <28762.1541528901@sss.pgh.pa.us> References: <4738198.8KVIIDhgEB@nb.usersys.redhat.com> <22881.1541515786@sss.pgh.pa.us> <28762.1541528901@sss.pgh.pa.us> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Scanned-By: MIMEDefang 2.79 on 10.5.11.12 X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.43]); Wed, 07 Nov 2018 12:56:01 +0000 (UTC) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk On Tuesday, November 6, 2018 7:28:21 PM CET Tom Lane wrote: > I wrote: > > Yeah. The long and short of this is that we're trampling on namespace > > that reasonably belongs to Ruby --- if they had some functions named > > "pg_something" and complained about a collision with libpq, would we > > change? Nope. So really we should rename these. > > > Barring objections I'll go make this happen shortly. > > Done. I realized that the immediate problem, rb_iterate(), was only > added as of PG v10, which may explain why we hadn't heard complaints > about this till now. So I've made the change only as far back as v10. > In principle we could change the rbtree code in 9.5/9.6 as well, but > I think that's more likely to create problems than fix any. The 'rb_iterate' seems to exist at least in REL9_2_STABLE branch, so it is probably much older. No need to backpatch of course -- just saying. That said, I'm still not sure how this could work before ... Maybe it has not been working for some time. Pavel