Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1dovJP-0005yw-9T for pgsql-hackers@arkaria.postgresql.org; Mon, 04 Sep 2017 17:37:27 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1dovJO-0004EO-SN for pgsql-hackers@arkaria.postgresql.org; Mon, 04 Sep 2017 17:37:26 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1dovHs-0001WP-9Z for pgsql-hackers@postgresql.org; Mon, 04 Sep 2017 17:35:52 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1dovHl-00016f-ER for pgsql-hackers@postgresql.org; Mon, 04 Sep 2017 17:35:51 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id v84HZe0b005957; Mon, 4 Sep 2017 13:35:40 -0400 From: Tom Lane To: "Daniel Verite" cc: "Fabien COELHO" , "Robert Haas" , "Pavel Stehule" , "Corey Huinker" , "PostgreSQL Developers" Subject: Re: Variable substitution in psql backtick expansion In-reply-to: <22a8687d-c192-4bdc-8d4b-053a094d641b@manitou-mail.org> References: <22a8687d-c192-4bdc-8d4b-053a094d641b@manitou-mail.org> Comments: In-reply-to "Daniel Verite" message dated "Mon, 04 Sep 2017 19:14:31 +0200" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <5955.1504546540.1@sss.pgh.pa.us> Date: Mon, 04 Sep 2017 13:35:40 -0400 Message-ID: <5956.1504546540@sss.pgh.pa.us> List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org "Daniel Verite" writes: > The two-space left margin on the entire block does not add that > much to readability, IMV, so maybe we could reclaim these > two characters. Well, it's a sub-list of the entire output of helpVariables(), so I think some indentation is a good idea. > That would look like the following, for example, with a 3-space margin > for the description: > AUTOCOMMIT > If set, successful SQL commands are automatically committed But we could do something close to that, say two-space indent for the variable names and four-space for the descriptions. > To me that looks like a good trade-off: it eases the size constraints > for both the description and the name of the variable, at the cost > of consuming one more line per variable, but that's why the pager > is for. Yeah, we're already past the point where it's likely that helpVariables()'s output would fit on one screen for anybody, so maybe this is the best way. regards, tom lane -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers