Subject: Guidance Needed for Testing PostgreSQL Patch (CF-5044)

From: postgresql_contributors <[email-masked]>
Date: Fri, 29 Nov 2024 11:04:11 +0000

Hi,
I recently installed and tested the CF-5044 patch using the query provided on the PostgreSQL community page but could not confirm its functionality. I followed the standard process:

  1.  Applied the patch using  git.
  2.  Rebuilt PostgreSQL from source (./configure, make, make install).
  3.  Tested with the suggested query after restarting PostgreSQL.

I would appreciate your guidance on verifying patch functionality and ensuring compliance with community testing standards. If there are additional steps or tools I should use, please let me know.
Thank you for your support as I represent Newt Global in contributing to the PostgreSQL community.
Best regards,
Team from Newt Global

---

From: Cédric Villemain <[email-masked]>
Date: Fri, 29 Nov 2024 19:05:46 +0100

On 29/11/2024 12:04, postgresql_contributors wrote:
> Hi,
> I recently installed and tested the CF-5044 patch using the query 
> provided on the PostgreSQL community page but could not confirm its 
> functionality. I followed the standard process:
>
>  1. Applied the patch using |git|.
>  2. Rebuilt PostgreSQL from source (|./configure|, |make|, |make
>     install|).
> I would appreciate your guidance on verifying patch functionality and 
> ensuring compliance with community testing standards. If there are 
> additional steps or tools I should use, please let me know.

That's welcome!

Maybe you'll find this wiki of interest:
https://wiki.postgresql.org/wiki/Reviewing_a_Patch in this page there is 
also a link to https://www.postgresql.org/docs/current/source.html
Which is a nice place to explore probably.

I hope it'll help

---
Cédric Villemain +33 6 20 30 22 52
https://www.Data-Bene.io
PostgreSQL Support, Expertise, Training, R&D