Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1trRi6-003vr1-D1 for pgsql-hackers@arkaria.postgresql.org; Mon, 10 Mar 2025 01:13:38 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1trRi3-00HPfx-El for pgsql-hackers@arkaria.postgresql.org; Mon, 10 Mar 2025 01:13:35 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1trRi3-00HPfp-0f for pgsql-hackers@lists.postgresql.org; Mon, 10 Mar 2025 01:13:35 +0000 Received: from sss.pgh.pa.us ([68.162.161.243]) by makus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1trRi0-001wDg-1e for pgsql-hackers@lists.postgresql.org; Mon, 10 Mar 2025 01:13:33 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 52A1DSB9641587; Sun, 9 Mar 2025 21:13:28 -0400 From: Tom Lane To: David Rowley cc: =?UTF-8?Q?=C3=81lvaro_Herrera?= , pgsql-hackers@lists.postgresql.org Subject: Re: Printing window function OVER clauses in EXPLAIN In-reply-to: References: <202503091412.mzlgmzmmzwim@alvherre.pgsql> <279724.1741535141@sss.pgh.pa.us> <616793.1741558789@sss.pgh.pa.us> Comments: In-reply-to David Rowley message dated "Mon, 10 Mar 2025 13:14:49 +1300" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <641585.1741569208.1@sss.pgh.pa.us> Date: Sun, 09 Mar 2025 21:13:28 -0400 Message-ID: <641586.1741569208@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk David Rowley writes: > What are your thoughts on being a bit more brief with the naming and > just prefix with "w" instead of "window"? Looking at window.out, I see > that the EXPLAIN output does become quite a bit wider than before. I > favour the idea of saving a bit of space. There is an example in > src/sgml/advanced.sgml that has "OVER w", so it does not seem overly > strange to me to name them "w1", "w2", etc. OK by me, any objections elsewhere? >> * In passing, I editorialized on the order in which the Run Condition >> annotation comes out: > I did it that way because "Rows Removed by Filter" is a property of > "Filter", so it makes sense to me for those to be together. It doesn't > make sense to me to put something unrelated between them. Hmm, OK. Do you think it could be sensible to put Run Condition before Filter, then? On the same grounds of "keeping related things together", it could be argued that Run Condition is related to the Window property. Also, the Run Condition acts before the Filter does, if I've got my head screwed on straight. regards, tom lane