public inbox for [email protected]
help / color / mirror / Atom feedFrom: Andrew Dunstan <[email protected]>
To: Álvaro Herrera <[email protected]>
To: Mahendra Singh Thalor <[email protected]>
Cc: [email protected]
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
Date: Mon, 14 Apr 2025 12:28:15 -0400
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
On 2025-04-14 Mo 8:20 AM, Álvaro Herrera wrote:
> On 2025-Apr-04, Andrew Dunstan wrote:
>
>> Non text modes for pg_dumpall, correspondingly change pg_restore
> I think the new oid_string_list stuff in this commit is unnecessary, and
> we can remove a bunch of lines by simplifying that to using
> SimplePtrList, as the attached illustrates. (Perhaps the names of
> members of the proposed struct can be improved.)
Sure, we can do it that way.
>
> I also propose to remove the open-coded implementation of pg_get_line.
>
> WDYT?
seems reasonable
>
> I'm also not sure about the double sscanf() business there ... There
> must be a better way to do this.
Yes, probably. I'll look into that if you like.
cheers
andrew
--
Andrew Dunstan
EDB: https://www.enterprisedb.com
view thread (4+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox