Subject: Re: Adding REPACK [concurrently]

From: Alvaro Herrera <[email-masked]>
Date: Mon, 16 Feb 2026 16:05:00 +0100

On 2026-Feb-16, Mihail Nikalayeu wrote:

> Hello!
> 
> > What kind of regression? There is no pg_stat_get_progress_info('CLUSTER')
> > call in system_views.sql.
> 
> I am about a direct call to that function (some monitoring tools may
> use it).

We don't promise compatibility using that interface, as far as I know.
Tools can update to accomodate the new definition -- assuming any exist
that actually do this.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/

---

From: Antonin Houska <[email-masked]>
Date: Mon, 16 Feb 2026 16:44:52 +0100

> We don't promise compatibility using that interface, as far as I know.

At least this particular function is not mentioned in the user documentation,
AFAICS.

-- 
Antonin Houska
Web: https://www.cybertec-postgresql.com