Subject: New developer papercut - Makefile references INSTALL

From: "Tim McNamara" <[email-masked]>
Date: Mon, 17 Jan 2022 14:11:59 +1300

Hello,

I encountered a minor road bump when checking out the pg source today. The Makefile's all target includes the following help message if GNUmakefile isn't available: 

  echo "You need to run the 'configure' program first. See the file"; \
  echo "'INSTALL' for installation instructions." ; \

After consulting README.git, it looks as though INSTALL isn't created unless the source is bundled into a release or snapshot tarball. I'm happy to submit a patch to update the wording, but wanted to check on the preferred approach.

Perhaps this would be sufficient?

  echo "You need to run the 'configure' program first. See the file"; \
  echo "'INSTALL' for installation instructions, or visit" ; \
  echo "<https://www.postgresql.org/docs/devel/installation.html>" ; \

-Tim

---

From: samay sharma <[email-masked]>
Date: Thu, 20 Jan 2022 16:29:34 -0800

On Wed, Jan 19, 2022 at 4:58 PM Tim McNamara <[email-masked]> wrote:

> Hello,
>
> I encountered a minor road bump when checking out the pg source today. The
> Makefile's all target includes the following help message if GNUmakefile
> isn't available:
>
> After consulting README.git, it looks as though INSTALL isn't created
> unless the source is bundled into a release or snapshot tarball. I'm happy
> to submit a patch to update the wording, but wanted to check on the
> preferred approach.
>

I noticed a similar thing in the README of the github repository. It asks
to see the INSTALL file for build and installation instructions but I
couldn't find that file and that confused me. This might confuse other new
developers as well. So, maybe we should update the text in the README too?

Regards,
Samay